ICSdroid 1.1 for Android crashing on sync



  • I downloaded ICSdroid from the Google Play store recently. Initially things were working fine. The ability to subscribe to https feeds with authentication is crucial for our clients to access our iCal feed. Then one day ICSdroid suddenly started to crash every time it went to update the subscription. I think that at about that time we updated the certificates on the server that I was subscribed to. Unfortunately the crash itself gives me no information.

    To try and work out what was going on I pulled down the open source project for ICSdroid. After a bit of messing around I was finally able to launch this from Android Studio directly on my device (a Samsung Note 2 running android 4.4.2). This including pulling in the latest versions of MemorizingTrustManager and ical4android (since cloning the repository did not automatically pull in the required files). Upon running it (for over a week now) I have had no problems whatsoever. The feed is updating perfectly every time. However, if I remove this and use the version on the Play store it breaks straight away.

    It is possible that there was a certificate issue in MemorizingTrustManager which has been fixed since 1.1 was put onto the Google Play store. This would explain why the 'official' release breaks while the version I built from source is fine for me.

    Is it possible to investigate this and, if necessary, update the version on the Google Play store? We are wanting to recommend this as a solution for our clients to be able to easily handle subscriptions to iCal feeds. Ideally we would like to be able to simply point them at the Play store, rather than having to deal with distributing a solution ourselves that is built from source. Unfortunately, with a crash like this, that is not a viable option at this time.


  • developer

    Hello,

    Can you please send a crash report in Play Store? Then we get a stack trace to see what's the problem.



  • I sent a crash report in a couple of days ago. I can send in another one now if you like.



  • I have just sent through another crash report


  • developer

    Thanks, I'll have a look.


  • developer

    The crashes are caused by a problem which is already fixed in master, thus there are no problems with the latest version.

    I hope that I can make a new release soon, ideally with (partial) support for redirects.


  • developer

    The fix can be found in version 1.2 which has just been released.


  • developer

    Can you please confirm whether it works with 1.2? Then I can tag the thread as solved.



  • That looks like it has fixed it. Thanks for the quick reply.


Log in to reply
 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.