Missing capabilities: Invalid DAV response: No Cardav ou CalDav available



  • Hi,

    When I try to add my ownCloud account on DAVdroid, I have this error "Missing capabilities: Invalid DAV response: No Cardav ou CalDav available"

    My ownCloud server is operational elsewhere : inside Thundebird or via Web Interface.

    I have this configuration :

    • Android 4.4.4
    • ownCloud 8.2.2
    • DAVdroid 0.8.4

    I try to activate debug or log file to have more details but I don't know how to do this.

    Any idea ?


  • developer

    You have to

    1. either set up well-known URLs or
    2. provide an URL to a CalDAV/CardDAV service,

    otherwise DAVdroid can't find the CalDAV/CardDAV URLs (it won't guess).

    See https://davdroid.bitfire.at/configuration/owncloud/ for details.



  • On my owncloud server, I have this result :

    78.213.xxx [09/Feb/2016:20:58:46 +0100] "PROPFIND /.well-known/carddav HTTP/1.1" 302 154 "-" "DAVdroid/0.8.4"
    78.213.xxx [09/Feb/2016:20:58:47 +0100] "PROPFIND /remote.php/carddav/ HTTP/1.1" 503 6493 "-" "DAVdroid/0.8.4"
    78.213.xxx [09/Feb/2016:20:58:47 +0100] "PROPFIND /caldav HTTP/1.1" 302 154 "-" "DAVdroid/0.8.4"
    78.213.xxx [09/Feb/2016:20:58:48 +0100] "PROPFIND /remote.php/caldav HTTP/1.1" 503 6493 "-" "DAVdroid/0.8.4"
    78.213.xxx [09/Feb/2016:20:58:48 +0100] "PROPFIND /remote.php/caldav HTTP/1.1" 503 6493 "-" "DAVdroid/0.8.4"
    78.213.xxx [09/Feb/2016:20:58:49 +0100] "PROPFIND /.well-known/caldav HTTP/1.1" 302 154 "-" "DAVdroid/0.8.4"
    78.213.xxx [09/Feb/2016:20:58:50 +0100] "PROPFIND /remote.php/caldav/ HTTP/1.1" 503 6493 "-" "DAVdroid/0.8.4"
    78.213.xxx [09/Feb/2016:20:58:50 +0100] "PROPFIND /caldav HTTP/1.1" 302 154 "-" "DAVdroid/0.8.4"
    78.213.xxx [09/Feb/2016:20:58:51 +0100] "PROPFIND /remote.php/caldav HTTP/1.1" 503 6493 "-" "DAVdroid/0.8.4"
    78.213.xxx [09/Feb/2016:20:58:52 +0100] "PROPFIND /remote.php/caldav HTTP/1.1" 503 6493 "-" "DAVdroid/0.8.4"
    
    

    The result is the same with URLs :

    On another hand, with Thunderbird/Ligthning, I have theses results when I synchronize with this kind of adress : https://owncloud.myserver.net/remote.php/calendarplus :

    78.213.xxx [09/Feb/2016:21:02:32 +0100] "PROPFIND /remote.php/calendarplus/calendars/User/personnel/ HTTP/1.1" 207 401 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.5.1 Lightning/4.0.5.2"
    78.213.xxx [09/Feb/2016:21:02:33 +0100] "PROPFIND /remote.php/calendarplus/calendars/User/professionel/ HTTP/1.1" 207 404 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.5.1 Lightning/4.0.5.2"
    78.213.xxx [09/Feb/2016:21:02:33 +0100] "PROPFIND /remote.php/calendarplus/calendars/User/concerts/ HTTP/1.1" 207 160749 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.5.1 Lightning/4.0.5.2"
    

    And in my nginx conf, I have this :

            rewrite ^/caldav(.*)$ /remote.php/caldav$1 redirect;
            rewrite ^/carddav(.*)$ /remote.php/carddav$1 redirect;
            rewrite ^/webdav(.*)$ /remote.php/webdav$1 redirect;
    
    

    and this :

            location / {
                    # The following 2 rules are only needed with webfinger
                    rewrite ^/.well-known/host-meta /public.php?service=host-meta last;
                    rewrite ^/.well-known/host-meta.json /public.php?service=host-meta-json last;
    
                    rewrite ^/.well-known/carddav /remote.php/carddav/ redirect;
                    rewrite ^/.well-known/caldav /remote.php/caldav/ redirect;
    
                    rewrite ^(/core/doc/[^\/]+/)$ $1/index.html;
    
                    try_files $uri $uri/ index.php;
            }
    
    

    What's going wrong with Davdroid ?



  • OK I got it !
    I have installed the last Davdroid version (0.9.1.3).
    After a retry to create an account, the error message changed and give me access to the log !
    And it was wrong permissions on the owncloud/apps folder

    I don't understand why it was working with Lightning and not with Davdroid, but I'm happy now :)


Log in to reply
 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.