Strange entries in logcat



  • Hi,

    I have a strange issue with DAVdroid 0.9.1.3. Don't know if it related to this version only, haven't tested other versions yet.
    Before posting this message I've completely wiped DAVdroid and Tasks v1.1.6 data, uninstalled and installed again (Tasks before DAVdroid as noted in official webpage) and reconfigured my account.
    I'm running Baikal 0.2.7 on a self-hosted Pi (Raspbian Jessie) behind NGINX and using an SSL certificate provided by Let's Encrypt.

    From time to time, DAVdroid autosync doesn't work, no matter how many times I force sync. What I have to do get sync working gain is to go into the account settings, open any setting (could be username, password, debug option) and save without changing. After doing so, autosync works again.

    I'm attaching logs:

    nginx server log: http://pastebin.com/rjk2de7T (the entries related to a success, no entries for failures)
    logcat: http://pastebin.com/bAyxQXtJ
    davdroid-debug: http://pastebin.com/bDk4BfX9

    Let me know if you need more information/logs.

    Regards!



  • Couple of minutes ago I've tried to sync manually and I got the same issue. Every time I tap manually to force sync it does nothing and populate a little more the logfile.

    Here's a log right after experiencing the non-synching issue.
    http://pastebin.com/Sgb8MvKA

    and this is the way it appears http://turl.ca/tbxkvkw

    in logcat the only entry when I tap "sync now" is
    D OpenGLRenderer: endAllStagingAnimators on 0x7f8e71c400 (ListPopupWindow$DropDownListView) with handle 0x7f8e3620c0
    I guess that's only related to the disappearing box



  • Yesterday I've reduced the sync time from 1440 minutes to 120 minutes and during the day it was working flawlessly. I've noticed that the issue appears overnight when I leave the phone in airplane mode. This morning it synced ad 07:26 and then got stuck again, same entries in the logs.

    Do you have any advice on how to troubleshoot this?

    Regards.



  • I've tried changing more options but I still have the same result - after some random time autosync stop working.
    The only way to unblock/fix the issue is to tap just once davdroid account settings.

    Simply tapping the option unblocks the synchronization. I'm unable to find any useful information in the logs.
    Any advice on how I can pinpoint the issue?

    I forgot to mention that I'm running Cyanogenmod 13 (nightly) on LG G4

    Regards.



  • After much digging I wasn't able to find a solution to this.

    I've finally completely wiped the phone and reinstalled Cyanogenmod + all the software and DAVdroid is now working as expected.

    Regards.


  • developer

    Hello,

    I can't imagine that this problem is caused by DAVdroid. So I'll mark this as solved until there are reasonable hints how DAVdroid could be related to this.


Log in to reply
 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.