[solved] Emoji support



  • Hi,
    I'm running Horde Groupware 5.2.10 and can't tell if this problem is on the side of DAVdroid or of Horde, but since the support here is better I've wanted to ask here first.

    I've tried putting emoji into one of my appointments (because my Android keyboard offered them and I figured I'd just try it out). This didn't just not work and get removed, but the text even got cut off completely with the beginning of the emoji.

    I have tested it both in the title and in the note field of my appointment. In both cases, the same thing happens. Complete text gets cut off once the first emoji appears.

    I don't know how emoji are supposed to be handled (I don't know the RFCs), but since more and more users can type them in, I believe this should be handled more gracefully. Especially, there should not be a cut-off of the whole text but the emojis should just be removed so the rest stay readable. Maybe one should even print a warning message on sync because effectively, the appointment is changed compared to the user input.

    If anyone could test this with other servers, that'd be great.


  • developer

    @Natanji: Emojis are just Unicode symbols. DAVdroid handles character sets correctly (apart from yet unknown bugs). I have just tried it out, and it works perfectly (with Radicale). I'm quite sure this is a Horde bug.



  • Thank you for the quick reply, I will contact Horde.


Log in to reply
 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.