ca-flag not set in certificate



  • Hi,
    I needed to renew my certificate from startssl for my own server www.songeasy.de.
    Until then everything went fine, I was able to syncronize my owncloud calender and contacts.
    I then tried to update my certifcate on startssl, which gave me new key, cert and pem files.
    When now logging into my phone I am asked I I want to accept an unkown certificate (see attached screenshot)0_1451985101522_device-2016-01-05-100334.png
    It says the certificate origins from an unkown certification authority although at the bottom it identifies StartCom correctly.
    I have to click accept by four times to get rid of this window.
    CAdroid tells me about an missing CA-Flag.
    0_1451985871902_device-2016-01-05-102414.png
    Don't know how to add this flag. The certificate comes from StartCom, not self signed and my key has no flag option?
    Searched google and tried with pem and root certificates but didn't found any appicable solutions.
    My webserver is apache2, DavDroid and CADroid are the newest version.
    Any suggestion what i have to do?


  • developer

    If you only want to use DAVdroid, just delete all user certificates from the Android trust store. Then "Always" accept the certificate in DAVdroid and it should work.

    If you want to other other apps with this certificate too, it must have a CA flag so that you can impot it into Android.



  • There are no user certificates.
    Disabled a system certificate of StartCom.
    Needed to click the accept dialog eight times again this morning.
    sigh :-(


  • developer

    @rekisum said:

    There are no user certificates.
    Disabled a system certificate of StartCom.
    Needed to click the accept dialog eight times again this morning.
    sigh :-(

    Well, in this case please create a thread in the DAVdroid forum and provide DAVdroid logs.


Log in to reply
 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.