Error creating account in 0.9.1.2, works on a test account and with 0.8.0.0



  • I have an error creating an account on https://davical.couder.eu/caldav.php/
    (or https://davical.couder.eu/caldav.php/admin) user : admin
    No resource are found.
    But these resources exist as they are used with another smartphone running Davdroid 0.8.0.0, and too https://davical.couderc.eu/caldavzap/ and https://davical.couderc.eu/carddavmate/
    And It works on a test account (user:test password:test) https://davical.couder.eu/caldav.php/test
    I join the log file.

    0_1451465510222_davdroid-debug-1349774512.txt


  • developer

    I don't see any collections reported by the server in the logs…

    1. The server has returned https://davical.couderc.eu/caldav.php/admin/as the address book / calendar home set.
    2. DAVdroid tries to enumerate the entries in the home set, but the server returns only /caldav.php/admin/calendar-proxy-read/ and /caldav.php/admin/calendar-proxy-write/, both are neither address books nor calendars.
    3. So, there are no resources to add.

    Can you maybe provide the log file of the (working) test account? Logs of 0.8 would also be interesting, because I don't know how it can detect resources, when there are none.



  • 1- Thank you for so prompt answer
    2- I wanted to compare log with test account, but I do not know how to get these logs ! (log is available in case of failure, but not in case of success)
    3- Problems may be due to bad parametrisation of davical server, as it is under nginx server and this is not common. The big change is changing to letsencrypt certificates.
    4- I cannot reproduce the problem with my personal 0.8.0.0. smartphone as it is running very fine with this account and I need it running. But...
    5- I have tried creating an account with and old 0.8.0.0 apk (found on an old unused smartphone where Fdroid was not up to date) and it is the same result than 0.9.1.2 !!! So I think the problem is not dependant on Davdroid version.



  • @rfc2822 I have found a way to get the logs of the working test account initialisation with socat (on the davical server)0_1451635479201_test


Log in to reply
 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.