• I have worked with all DAVdroid and ownCloud 6.0.2.
    but i recently updated to version DAVdroid and synchronizing stopped with an error:

    Synchronization phase: 7
    Account name: Manager
    Authority: com.android.contacts
    REPORT https://desktop.buxarn…xarnetmanager/manager/
    Content-Length: 184
    Content-Type: application/xml; charset=utf-8
    Depth: 1
    <?xml version='1.0' encoding='UTF-8' ?><CARD:addressbook-query xmlns="DAV:" xmlns:CARD="urn:ietf:params:xml:ns:carddav"><prop><getetag /></prop><CARD:filter /></CARD:addressbook-query>
    http/1.1 404 Not Found
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Connection: keep-alive
    Content-Length: 255
    Content-Type: application/xml; charset=utf-8
    Date: Fri, 11 Dec 2015 18:05:23 GMT
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    OkHttp-Received-Millis: 1449857122525
    OkHttp-Selected-Protocol: http/1.1
    OkHttp-Sent-Millis: 1449857111634
    Pragma: no-cache
    Server: nginx
    X-Powered-By: PHP/5.4.22
    <?xml version="1.0" encoding="utf-8"?>[LF]
    <d:error xmlns:d="DAV:" xmlns:s="http://sabredav.org/ns">[LF]
    <s:message>Card not found</s:message>[LF]
    at.bitfire.dav4android.exception.NotFoundException: 404 Not Found
    at.bitfire.dav4android.exception.NotFoundException: 404 Not Found
    at at.bitfire.dav4android.DavResource.checkStatus(DavResource.java:273)
    at at.bitfire.dav4android.DavResource.checkStatus(DavResource.java:286)
    at at.bitfire.dav4android.DavAddressBook.addressbookQuery(DavAddressBook.java:68)
    at at.bitfire.davdroid.syncadapter.ContactsSyncManager.listRemote(ContactsSyncManager.java:118)
    at at.bitfire.davdroid.syncadapter.SyncManager.performSync(SyncManager.java:172)
    at at.bitfire.davdroid.syncadapter.ContactsSyncAdapterService$ContactsSyncAdapter.onPerformSync(ContactsSyncAdapterService.java:52)
    at android.content.AbstractThreadedSyncAdapter$SyncThread.run(AbstractThreadedSyncAdapter.java:254)
    DAVdroid version: (86) Fri Dec 11 21:06:53 EET 2015
    Installed from: APK (directly)
    JB Workaround installed: no
    System-wide synchronization: automatically
    Account: MyPhone
    Address book sync. interval: 1440 min
    Calendar sync. interval: 1440 min
    OpenTasks sync. interval: manually
    Account: MyMail
    Address book sync. interval: 1440 min
    Calendar sync. interval: 1440 min
    OpenTasks sync. interval: manually
    Account: Manager
    Address book sync. interval: 1440 min
    Calendar sync. interval: —
    OpenTasks sync. interval: manually
    Android version: 4.2.2 (thl_T100S.159D.A2.JB9.FHD.EN.16P256.IMX135.MT6592GW.20140225)
    Device: Thl thl T100S (Android)
  • admin

    Did you try to re-install DAVdroid? A jump from 0.6 to 0.9 is quite a big one… You OC seems to be very old too.

  • when reinstalling DAVdroid I will not lose changes in the phone’s address book? They do not sync with the server

  • admin

    You can look in your ownCloud. If the contacts are shown there they will be synced again to your phone after re-installing. If they’re not on the server you will loose contacts that have not been snyced when re-installing DAVdroid.

    The best would be to update you ownCloud server…

  • do you think that you need to update the server ownCloud?
    I thought that if you use the standard carddav version changes should not affect the connection.
    I used 3 phones, two of them connect to the 3rd phonebook, on the third one.
    The result is the following:
    Phone 1 (Android 4.2.2.) Is synchronized with the address book number 3 (with 1 and 2 does not work)
    Phone 2 (Android 4.2.2.) Is synchronized with the phonebook 1 and 2 only when you add a contact, add a contact to more accurately ownCloud, but no more synchronized. 3 phone book all right.
    3 Phone (Android 4.2.2.) - The same as the phone 2, but connected only Phonebook 2 similar way, add in the fact that the phone is on ownCloud server, but most of the synchronization does not occur.

    there are 4 phone, the old version 0.6 adapted for Androyd 2,2,6, it all works and how to work.
    check if everything is all recorded on the server, I’ll reinstall DAVdroid

  • DAVdroid reinstalling has not helped

  • developer

    @BuxarNET said:

    do you think that you need to update the server ownCloud?

    It’s a known bug of old OwnCloud versions that they return 404 for a collection when only a single resource is not available.

    Please update your OwnCloud (including contacts and calendar apps) to the latest version.

  • Thank you, yet there is no way to update the server. for my home Linux are no new versions of the desktop version, I’m afraid that when you upgrade the server will have problems with synchronization of documents.
    tried to uninstall davdroid, clean install the latest version did not help.
    Version failed to start properly and it worked.

Similar topics