[Amazon Store] ical4j exception when syncing calendars



  • Hi,
    as said already in sync-error
    I experience a problem when syncing with davdroid//0.8.4.1 from Owncloud 8.1.1 on a raspi to my samsung S5 mini (Android 4.4.2). I get the contacts synced in both directions and the list of calendars, but no entries in calendars and tasks.
    At the end of
    log.txt
    you can see the error appearing.
    I receive the Message: "DAVdroid angehalten".

    I already reinstalled davdroid with no effect.

    Sorry for reposting, but as it was said my problem didnt fit the other topic.

    --74alex



  • Hi,

    I experienced the exact same problem. I'm using DAVdroid 0.8.4.1 with Owncloud 8.1.1. from Samsung S5 with Android 5.0. Contacts work well, but calendar does not sync. This is an excerpt from the log:

    V/davdroid.URIUtils(15465): Normalized URI /owncloud/remote.php/caldav/calendars/user1/pers%c3%b6nlich/owncloud-0ede65cc91431dbe9f864a193cea1478.ics -> /owncloud/remote.php/caldav/calendars/user1/pers%C3%B6nlich/owncloud-0ede65cc91431dbe9f864a193cea1478.ics assuming that it was an URI or path name
    D/davdroid.WebDavResource(15465): Processing multi-status element: https://123.123.123.123/owncloud/remote.php/caldav/calendars/user1/persönlich/owncloud-0ede65cc91431dbe9f864a193cea1478.ics
    D/HttpClient(15465): Connection [id: 0][route: HttpRoute[{s}->https://123.123.123.123:443]] can be kept alive for 2.0 seconds
    D/HttpClient(15465): Connection released: [id: 0][route: HttpRoute[{s}->https://123.123.123.123:443]][total kept alive: 1; route allocated: 1 of 2; total allocated: 1 of 3]
    E/AndroidRuntime(15465): FATAL EXCEPTION: SyncAdapterThread-1
    E/AndroidRuntime(15465): Process: at.bitfire.davdroid:sync, PID: 15465
    E/AndroidRuntime(15465): java.lang.ClassCastException: net.fortuna.ical4j.model.component.XComponent cannot be cast to net.fortuna.ical4j.model.component.VEvent
    E/AndroidRuntime(15465): 	at at.bitfire.davdroid.resource.Event.parseEntity(Event.java:125)
    E/AndroidRuntime(15465): 	at at.bitfire.davdroid.resource.WebDavCollection.multiGet(WebDavCollection.java:121)
    E/AndroidRuntime(15465): 	at at.bitfire.davdroid.syncadapter.SyncManager.pullChanged(SyncManager.java:208)
    E/AndroidRuntime(15465): 	at at.bitfire.davdroid.syncadapter.SyncManager.synchronize(SyncManager.java:96)
    E/AndroidRuntime(15465): 	at at.bitfire.davdroid.syncadapter.DavSyncAdapter.onPerformSync(DavSyncAdapter.java:138)
    E/AndroidRuntime(15465): 	at android.content.AbstractThreadedSyncAdapter$SyncThread.run(AbstractThreadedSyncAdapter.java:259)
    

    And this is the calendar file its trying to sync:

    BEGIN:VCALENDAR
    VERSION:2.0
    PRODID:-//bitfire web engineering//DAVdroid 0.8.4.1 (ical4j 2.0-beta1)//EN
    BEGIN:VEVENT
    DTSTAMP:20150901T065009Z
    UID:7210eeedfa
    DTSTART:20150202T173000
    DTEND:19700101T010000
    RRULE:FREQ=WEEKLY;WKST=MO;UNTIL=20150906T153000Z;INTERVAL=1;BYDAY=MO
    SUMMARY:xyz
    END:VEVENT
    END:VCALENDAR
    

    I tried to reinstall the app as suggested but to no avail.

    I'm looking forward to any helpful comments.

    Pat



  • @PattyCode said:

    I experienced the exact same problem. I'm using DAVdroid 0.8.4.1 with Owncloud 8.1.1. from

    Hi,

    Me too, I experienc the exact same problem since I upgraded my OwnCloud to 8.1.1. Davdroid is crashing also with Owncloud 8.1.3.
    I'm using DAVdroid 0.8.4.1 on LG G2 and Android 4.4.2

    Thank you.


  • admin

    Thank you all for the numerous reports.

    We will have a look at it soon... At the moment I could'nt reproduce it myself...



  • Hi devvv4ever,

    I have made some tests. My wife who is using two Owncloud and CalDav has no error at all.
    So, it must be a data in some calendar that make the error occuring.

    I just make a copy of my Owncloud Calendar on a new account for you. How can I send you a private message to give you access on this account ?

    Thanks,
    Richard


  • developer

    @Novick Click on the user name (me or @devvv4ever), then "Chat"


  • admin

    Novick: Thank you for sending me the account. But (unfortunately) there were no errors with this calendar. It took very long to sync that whole thing (10-15 minutes), but it finally completed successfully. I could also update and write new events without problems. I've used my Galaxy S6 to test this.

    So... I don't know how I could help you further with this :expressionless:



  • Hi Devvv4ever....Ho....
    Very strange. Of course, I have tested this account and Davdroid crash after few seconds.

    I'll install the SDK to produce the verbose logs and more informations.



  • After updating today I get the same error message just more convenient. 😊


  • developer

    @Novick Did you install from Amazon Store?


  • developer

    @PattyCode @74alex Did you get DAVdroid from Amazon Store?



  • @rfc2822 indeed. ..


  • developer

    @74alex We have found out that the problem only occurs when installing DAVdroid from Amazon Store. We have contacted Amazon support as it must be a store problem – exactly the same .apk works when installed directly or from another store.

    Shall I send you the latest .apk via email?

    PS: The "more convenient" dialog also shows where the .apk has been installed from, to help finding such problems ;)



  • Now it works. The app from amazon seems to have an other signature.
    Thanks for the help.


  • developer

    @74alex Thanks for the confirmation. I don't know why Amazon modifies and corrupts our .apk. We'll investigate this issue.


  • developer

    We have found the reason for the problems: Amazon App Store removes the files in META-INF/services/* arbitrarily.

    If you have bought DAVdroid on Amazon App Store, we can of course send you a working .apk file, but please report this issue to Amazon App Store, as the bug is on their side. You won't be able to receive updates automatically until they have fixed this.

    See also: https://davdroid.bitfire.at/faq/entry/amazon-class-cast-exception



  • Hello everybody,

    has amazon fixed this problem?
    At the moment I'am using Version 9.0.4. Or should I move to f-droid store?

    Thanks in advance.

    Greetings,

    Torsten


  • developer

    @Torsten As you can read in the Amazon forum, the problem has been at least confirmed by Amazon, but not yet fixed.

    I don't know whether they will fix it at all – it would surely be helpful if you could post in the linked thread and mention that you're affected by the problem.

    In the meanwhile, I recommend to use another store; or I can send you the latest .apk.



  • Thanks for your help rfc2822.
    I think I switch to another store. Can't bother you everytime when a new version is out :-)
    I hope my post in the amazon forum helps.

    Greetings,

    Torsten


  • developer

    Maybe it would accelerate things if you post in the Amazon forum thread that you are affected by the problem…


Log in to reply
 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.