[solved] Can't sync contacts (calendar ok)

  • Still nothing in aLogcat with 0.3.5 and still fails… 😞
    I have deleted the contacts in my baikal server with another client, as my contacts on my phone are newer and up to date : 190 on it and 0 on the server => try to sync and nothing changed…

    I have activated the logs on baikal, and that’s what I’ve got, in access logs, not in error logs… :
    xxx.xxx.xxx.xxx - - [27/Oct/2013:15:48:51 +0100] “DELETE /card.php/addressbooks/xxxx/default/C5E24A1C-BAA0-0001-C61E-EB271170BB80.vcf HTTP/1.1” 401 304 “-” “DAVdroid”
    xxx.xxx.xxx.xxx - - [27/Oct/2013:15:48:51 +0100] “DELETE /card.php/addressbooks/xxxx/default/C5E24A1C-BAA0-0001-C61E-EB271170BB80.vcf HTTP/1.1” 404 266 “-” “DAVdroid”

    May it help you ?

  • I have the same problem with owncloud and cyanogenmod 10. The address book is from another user who shared his address book.

  • developer

    @KasumiNinja: I’m not sure that I understand the bug report completely. Could you please give summarize it for me, including steps to reproduce?

  • Hello,

    same behavior on an AOKP install (latest milestone for nexus4), as well on stock HP slate 7. I can sync my calendar events between them and my owncloud instance (latest 5.x), but no way to sync my contacts.
    I have about 110 contacts, without any special field.
    There’s apparently no error reported by davdroid nor my owncloud installation…

    I’m using latest f-droid available release of davdroid.



  • Hi, I’m using DAVdroid 0.3.6-alpha (installed via F-Droid) on a Samsung GT-I9000 running CyanogenMod 10.1.3 without Google Apps and I’m trying to sync my contacts with my OwnDrive account (they are running owncloud 5.0.12). I have two separate address books (one for private contacts, one for business contacts).

    As I understand it, right now it’s impossible to sync both address books; but apart from that I’m also affected by this bug: I can’t sync any of my contacts.

    How to reproduce: 1. Install DAVdroid, 2. Settings -> Accounts -> Add account -> DAVdroid -> fill out Root URL, User name, Password -> Select one of the two Address books (doesn’t matter which one) -> Contacts won’t be synchronized (I have no local contacts, so I won’t see any contacts on my phone).

    When I go to Settings -> Accounts -> DAVdroid the symbol for the sync account for my contacts is green and the status message under the account name says “Sync is ON”. When DAVdroid tries to sync the account, the symbol changes its color to red for less than a second, then it’s green again. I get no error message.

    When I go to Settings -> Accounts -> DAVdroid -> [pick my OwnDrive sync account for contacts] there’s a grey sync symbol next to the box where you can toggle sync. When I hit “sync now”, the grey symbol rotates and the status message says “Syncing now…” for approximately 5 seconds.

    As I said: there’s no error message and this is all I get. The status message in the DAVdroid sync account list will never say something like “Last synced…”, it always says “Sync is ON”.

    Please tell me if you need more information.

    EDIT: I can reproduce this issue with DAVdroid 0.3.7-alpha on a fresh install of CyanogenMod 10.2 M1 (Android 4.3).

  • Issue still here with 0.3.7 alpha

  • developer

    Unfortunately, the sync mechanism of Android doesn’t provide a method to give the user an error message when some error occurs. Instead, there’s just the red icon. So I will have to rely on logcat/server logs instead.

    OwnCloud is known to send unencoded characters in URLs. This has been improved in 0.3.8 but of course I don’t know if this will fix it (I doubt it in this case).

    Can you provide either logcat/server log output or a test account with this problem and send it to play@bitfire.at?

  • @rfc2822 : I use Baïkal on my server, not owncloud, and all I have (in terms of logs when trying to sync) is what I have allready transmitted to you :
    theipoftheclient - - [09/Nov/2013:13:08:47 +0100] “DELETE /card.php/addressbooks/arno/default/C5E24A1C-BAA0-0001-C61E-EB271170BB80.vcf HTTP/1.1” 401 304 “-” “DAVdroid/0.3.6-alpha”
    theipoftheclient - - [09/Nov/2013:13:08:47 +0100] “DELETE /card.php/addressbooks/arno/default/C5E24A1C-BAA0-0001-C61E-EB271170BB80.vcf HTTP/1.1” 404 266 “-” “DAVdroid/0.3.6-alpha”

    It’s written “DAVdroid/0.3.6-alpha” but I have 0.3.7-alpha (I’ve just checked and reboot to be sure…).

  • I found a solution at least for my problems (sync with owncloud): I exported my contacts from the owncloud web-ui to a VCF-file and deleted all contacts, then I imported the contacts in Android. After that contact sync worked.

    I exported the contacts to a VCF-file from owncloud web-ui again and compared the old and the new files; it looks like a lot of trash was removed (for example really meaningless stuff from Evolution). @ arno-githib: I know you try to sync with Baïkal (BTW, sorry I hijacked your bug report) – but maybe your problems are related to the imported VCF-files as well.

  • I know you try to sync with Baïkal (BTW, sorry I hijacked your bug report)
    but maybe your problems are related to the imported VCF-files as well

    Maybe… but I did it the same way : import VCF into android, deleted all contacts on baïkal, and sync doesn’t work

  • developer

    Could this be the same as in issue #68 – usage of URLs with :?

  • I don’t think so, the URL entered in the config of the davdroid account follow this syntax :

  • developer

    no I mean if the vcards contain URLs with colons? do you have URLs in your vcards?

  • “colons” is “?”
    I exported all my contacts (on Android) in a vcf file, and I looked for a “?” : I have some.
    I then looked for “http” (to find url), but didn’t find any.
    Just in case : in the vcf file, it’s written :" VERSION:2.1" (android 4.2.2)

  • developer

    @arno-github colons are “:”, for instance in URLs
    URL:http://www.test.at would be valid in VCard 4 and invalid in VCard 3 while
    URL:http://www.test.at would be valid in VCard 3 and invalid in VCard 4

  • I don’t see the difference, exept “http://” isn’t part of the link on the second example…

    See what I have :
    $ grep ‘URL’ Contacts.vcf
    URL:www.mairie.fr (not the real name, transformed as a link by github)

  • developer

    Oh, github changed it. Difference again:
    URL:http://www.test.at would be valid in VCard 4 and invalid in VCard 3 while
    URL:http\://www.test.at would be valid in VCard 3 and invalid in VCard 4

    Which one do you have (see Github help for how to escape)?

  • I don’t have any of those, as written above… But I have a lot of colons in other fields !

  • developer

    Colons are OK to seperate field name and values, but not within the values. But maybe there’s another reason why it doesn’t work for you. I can only suggest not to import contacts or import sanitized, minimal VCFs until the problem has been identified.

  • I deleted the 2 colons present in the values, but it didn’t solve the problem.
    Maybe other special caracters can prevent from sync to work ? ("?", “/”, “!”…)

Log in to reply

Similar topics