Problems syncing contants with Baikal



  • I have a Baikal server, and while calendar synced fine, the contact list keeps erroring out. "Sync is currently experiencing problems. It will be back shortly" is all I get on the client.



  • It's syncing both for me with Baikal. Did you add a separate account for calendar and contacts? (I did).



  • In davdroid, yes.



  • Not sure if it matters, I have two addressbooks on Baikal, syncing only one of them.


  • admin

    This is because, according to the WebDAV standard, only one address book is allowed per account! You can also only select one address book when DAVdroid has found your resources. Multiple calendars per account are allowed though (also according to the standard), so thats why there is a checkbox in the section of davdroid to select them instead of a radio button.



  • And I did select only one of those resources/addressbooks/whatever.



  • Actually I just tried and it wouldn't let me add an account with the second resource, saying account already exists.


  • developer

    @viq: You need the latest version where accounts are named differently for different URLs.

    @devvv4ever: Not true. DAV servers may host several address books, but Android devices have only one address book, so at the moment, you can sync only one DAV address book to your device.

    The "sync is currently experiencing problems" is when DAVdroid got an exception. Do you know what logcat is / can you provide logcat output? Did you try the latest version?

    Can you try creating a new, empty address book/calendar and sync with DAVdroid - does it work?



  • Not sure if it's the same issue, but I get the same behaviour using a SOGo server: calendar seems to work just fine, but contacts always give that "Sync is currently experiencing problems. It will be back shortly".

    I had never used logcat but I just gave it a shot and it seems to complain that it can't parse some XML ("Problem reading XML in line 4 for external package at.bitfire.davdroid"). I do see a lot of XML bits here and there in the log, but I'm not sure how to extract the exact line that gives the error. Ideas welcome.

    BTW, contact sync works just fine in "CardDAV-Sync free beta".



  • @rfc2822 I am using latest version. I just tried creating a new account on Baikal, with just one address book and a couple entries in it, and it does sync. Interesting thing is, in the "People" application you have a setting on which contacts to show, one of possibilities is to do it by account, and DAVdroid is not on the list. Also the properties of contacts say "unsynced, only on the device", even though they got there via davdroid. And no, sorry, I don't know logcat, could you point me at a start point?

    @emanchado sadly the "CardDAV-Sync free beta" (which does work with multiple address books) does not sync all the fields.



  • @viq you can download the Android SDK from https://developer.android.com/sdk/index.html, then unpack it and, from the command-line, execute "./adb logcat" from the directory "sdk/platform-tools". You'll have to connect your phone to your computer with the regular USB cable and enable some "Debug mode" on the phone.

    About the CardDAV-Sync app, I just meant that my current assumption is that my data and server are probably fine, as there is another application that seems to parse it just fine. And in fact CardDAV-Sync seems to parse the reminders correctly, unlike DAVdroid (not complaining at all BTW, just stating my limited experience so far!).


  • developer

    Could you please test 0.3.4-alpha?



  • I tried, it does show the accounts in People application (even the ones with just calendar), contacts are shown as belonging to accounts, though still doesn't sync from the account with multiple address books.



  • Hm, I don't get any error messages or icons anymore, but I still don't get any contacts :-( Do you want some information from logcat? Anything in particular you're looking for? I'd rather not publish the whole logcat output here, but I can fish for interesting bits that don't contain personal information.

    Should I file my specific issue separately?


  • developer

    Yes, please file a specific issue, but after testing with 0.3.5 (I have just released it)



  • Works with 0.3.5, thank you!


Log in to reply
 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.