Everything seems to work except the drawing bit.

  • Hello all,

    I have hit a brick wall on this one and I hope someone out there can lend a helping hand. I am running Mageia 3 64 bit on my system.

    Now, I have installed this app on the tablet and installed and run the uinput driver. The network monitor seems to recognise the port that the app is trying to use, gimp recognises that there is a tablet available and checking the tablet itself it does seem to be sending data. If I try to run the driver again I get “error: prepare_socket(): Address already in use”. One thing I do not get are the dots in the terminal which suggest that input has been received.

    Of course despite all this I can’t seem to be able to draw anything.

    Checking various other posts about problems I think it may be a problem with the firewall in Mageia 3. I have tried to disable it but I don’t think it is working properly… I am not sure about this though.

    Any advice? Thank you in advance.

  • Ok I disabled the firewall and gone one step further. The cursor now moves around the screen and the coordinates are printed in the terminal.

    However, I cannot seem to get the thing to draw. I have tried it in mypaint but the cursor just moves around the screen.

    Will update tomorrow.

  • admin

    did you set the input device to “screen” in mypaint/gimp input devices list?

  • Hi and thank you for responding.

    Yes I have tried playing with the input settings but it makes no difference. Even if I set it to disable I am still able to move the cursor. Despite this I can still use the tablet as a mouse ie selecting menus, brushes and so on.

    In the configure input for the tablet I have X:1, Y:2,Pressure:3, Xtilt none, Y tilt none, Wheel none and it says"The axis ‘x’ has no curve.

    This is a typical line printed in the terminal “.x: 15559, y: 15375, pressure: 16383”. I am sure my tablet doesn’t have pressure sense but I was wondering if 16383 is significant in any way. This is the only number it gives though.

  • Latest test.

    I can get mypaint working well but gimp still no longer wants to play. I think from a little more jiggery pokery I can get it to play nice, therefore I will put this thread as solved.


  • i’m having this same problem. finally got the cursor to move, but will not actually draw anything. not sure what to do.

  • admin

    do you use GIMP on this? If so, did you set the input device “network-tablet” to screen?

    PS: Thank you very much for the donation 😉

  • yes, i’ve set the mode to screen. the window says x axis has no curve.

    not sure what the deal is now, i can’t draw with tablet, nor mouse, nor
    trackpad. opacity is @ 100%. i’ve quit and restarted gimp several times
    and the same thing happens. this may be unrelated.

  • thanks for your quick response. this is is FUCKIN AWESOME!!! WOOOHOOOOO!!!

    i completely removed and reinstalled GIMP and the problem persisted. i then trashed the .gimp folder in ~ which fixed it, except i lost a lot of settings 😞 UG!

    anyway, great job! i wanted to donate $5 but paypal wouldn’t let me change the amount… stupid.

  • ps, i know my donation is pretty insignificant, but to me it’s as if i’m paying for this app. thanks for making it free and open source 😉

Similar topics