Can't write contactname - it changes to nullnull



  • Contactsync between Synology NAS and Xperia Z3 (Android 4.4.4) does not work properly:
    If I create a new contact on the phone, the "name" field won't be saved. After syncing it is displayed as "nullnull"


  • developer

    Thanks for your report. Please read Reporting issues and provide all information mentioned there, including detailled steps to reproduce the issue, client and server software details, and verbose logs.

    Where is it displayed? On the phone?



  • Phone: Xperia z3, original rom android 4.4.4
    Client: Davdroid from googlePlay, V0.6.12
    Server: Synology DSM 5.1-5022 Update 2 with Carddav Server 5.2.0-0021

    Steps to reproduce the Problem:
    Connect to DS via LanIp without Ssl (to keep it simple). Create a new contact on the phone with just a name and telephone-nr. In the DAVDroid Account.
    After saving the contact details will be shown, but there is no name. If you edit the contact, the name field is empty.
    After syncing the name field will be changed to: "nullnull" - On the phone and server.

    Contacts which are downloaded from the server will have a name, but it is not possible to change it on the phone. Every other field is changeable.

    It seems, that the contact Editor cant save values in the name field. A friend tried the same steps with his motorola razr xt910, Android 4.1.2, and had the same issue.


  • developer

    @fabif Would it be possible for you to provide a test account so that we can reproduce and identify the problem?



  • Is it possible to write you a private message? I do not want to post login data publicly...


  • admin

    Sure, please send it to play@bitfire.at. Only the developers will receive this email. Thank you!


  • developer

    @fabif Did you already contact us? Is the issue still present?


  • developer

    Closing because of missing user response.



  • This probably a Sony "feature". I had the same issue using the CardDAV app from the play store.
    My setup:
    Phone: Sony Z3 compact with Android 5.0.2
    Client: CardDAV 0.4.13
    Server: Horde 5.2.6
    When you are creating or editing a contact on the phone, you can enter name and some "phonetic" names. Than the name will by ignored causing a "nullnull" name after syncing.
    But if you hit the extension button (arrow down symbol at the name fields) you can enter a proper first name and last name. After that syncing worked for me.
    I don't know DAVdroid, but let me know if this works for you.
    The Sony phone seems to be confused with all the naming features of carddav.



  • I can confirm that I have this issue as well on my Sony Z3. bummi2k's workaround works for me as well, but a real fix would make the app a lot easier to use for Sony users.



  • I have the same issue, please have a look a this.


  • developer

    @Itchy said:

    I have the same issue, please have a look a this.

    We don't have a Sony device for testing. Can you provide more details about your case? Did you try an alternative contacts app?



  • Yes, it still there.
    My Sony Z3 is fully updated.
    If I try to add ad Contacto to CardDAV / (in Sync with OSX-Server.app 5.2), the names come back with nullnull, I guess after sync.
    How can I provide more information for you? Perhaps I could let you on a Z3 remote?
    Best regards.
    re-book.


Log in to reply
 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.