Sync problems with Posteo

  • Hi!
    I just found out that all my events on my fairphone calender are missing. Thus I checked DAVdroid and found out that the account I use to synchronize my calender (a posteo-account) doesn’t exist any longer. I tried to set it up again, but after entering all relevant information (following those steps: a the app doesn’t react when I press the top right arrow to continue. I restarted my phone but the problem remains just the same.
    BTW my events are still saved in the posteo-account, I can access them via my computer.
    Any ideas?

    Best regards,

  • developer

    Duplicate of #391?

    Thanks for your report. Please read Reporting issues and provide all information mentioned there, including detailled steps to reproduce the issue and verbose logs.

  • Hi,

    I don’t think it is a duplicate of #391 because the problem is still the same directly after restarting the phone without any hint of a connection problem.
    I tried to provide the requested information, but things don’t work as described there- I installed SDK but cannot get it to communicate with my phone - although it is connected the DDMS doesn’t show any connected devices. Sorry.

  • developer

    Did you move/install DAVdroid to the SD card, too?

  • I’m not absolutely sure. But it might be so, because I configured it so that newly installed apps and updated apps shall be installed on / moved to SD card. So if there was a recent update DAVdroid might have been moved to the SD card. I removed it in the meantime because I was hoping a new installation might Geld. However it did Not and now I can’t install it Again due to some Java File not found exception.

  • developer

    DAVdroid must never be installed to the SD card. Do you have root access and possibly overriden the setting? As far as I know, this line should prevent the app from being installed anywhere than to the internal storage.

  • I now reinstalled DAVdroid from PlayStore (it didn’t work via FDroid as it always reported some on the main storage (not SD Card) and added my posteo account again. This worked.
    However now I get a synchronization error all the time: there are synchronization problems at the moment. Synchronization will continue soon. (in German “Bei der Synchronsisierung treten momentan Probleme auf. Sie wird in Kürze fortgesetzt”) as reported in #397 (and I don’t use Baikal). However, the problems persist for hours (and also after a reboot). Additionally only two of my three calenders are shown…

  • admin

    What server/service do you use?

    Do you have some kind of security guard or firewall running on your device maybe blocking connections?

    Could you provide logs? We can then take a closer look at it. Here is a short tutorial on it:

  • I use posteo so it is this address:
    I don’t have any security software running which would block connections.
    To me it makes no sense, that some events are synchronized, but some are obviously an old version (deleted events still appear) and one of three calenders doesn’ sync at all.
    I tried to get logs. But I didn’t manage: I installed android-SDK-linux on my computer and started the USB-debugging mode on the Fairphone, and run Dmms however, when I use the command > Device > run logcat I get the message “failed”. I couldn’t get adb running as describes in the link. However, dmms should use adb anyway?

  • I now tested the posteo configuration and oviously there is a problem there already: The lightning calender does not sync correctly to posteo and vice versa. So maybe it is not a DAVdroid related problem? I wrote already an email to the support…

  • developer

    Any news on this?

  • No. I haven’t received any answer from yet. However, two “normal”
    calendars work - only the birthday calendar doesn’t…
    Am 01.01.2015 21:06 schrieb “rfc2822”

    Any news on this?

    Reply to this email directly or view it on GitHub

  • developer

    Maybe the birthday calendar isn’t a real calendar? Please note that you can sync your contact birthday information with a virtual calendar on your device with Birthday Adapter

    I’ll close this issue for now. If there’s anything new that indicates a DAVdroid problem, please post here again and I’ll re-open the issue.

  • Hi.
    Yes, two days ago I finally received an email from posteo support stating
    that they have problems regarding reccuring dates. Thus it seems to be
    really a posteo bug.
    Thanks for your help!
    Am 01.01.2015 21:06 schrieb “rfc2822”

    Any news on this?

    Reply to this email directly or view it on GitHub

Log in to reply

Similar topics

  • 8
  • 6
  • 3