Invalid DAV response / OwnCloud 7.0.2 / well-known configured


  • developer

    Thanks for your report. Please read Reporting issues and provide all information mentioned there, including detailled steps to reproduce the issue and verbose logs.

    BTW, I’m prettry sure that’s a server issue:

    11-03 21:57:30.743 D/ch.boye.httpclientandroidlib.wire(4125): http-outgoing-145 >> “PROPFIND / HTTP/1.1[\r][\n]”

    11-03 21:57:31.298 D/ch.boye.httpclientandroidlib.wire(4125): http-outgoing-145 << “HTTP/1.1 405 Method Not Allowed[\r][\n]”



  • I’m a little confused here - as this new device uses details that are already working on a different device. I also use DAVdroid on my Nexus 5 without issue. Same server, and on another device with the same configuration details…

    Any suggestions on where to start? 😕


  • developer

    Ok, it might be related to trailing slashes again. Can you try to change the well-known redirection to /remote.php/carddav/ (with trailing slash at the end) and try again please?



  • Right you are:

            Redirect 301 /.well-known/carddav       /remote.php/carddav/
            Redirect 301 /.well-known/caldav        /remote.php/caldav/
    

    The above works correctly.


  • developer

    Ok.………… will be fixed…… thanks for the report.



  • Sorry to also bother you with this topic… But I have the same issue. And it doesn’t matter if I write the well-known redirection to /remote.php/carddav/ with trailing slash at the end or without.
    This worked all very well until the last update of DavDroid.Today I wanted to add my account again but run into this issue.
    I’m on Cyanogenmod 11-20141125-NIGHTLY-hammerhead

    Here is the log I’ve taken: https://gist.github.com/c35285f6563ca782e0d8


  • developer

    Sorry to also bother you with this topic… But I have the same issue. And it doesn’t matter if I write the well-known redirection to /remote.php/carddav/ with trailing slash at the end or without.

    So it can’t be the same issue.

    Here is the log I’ve taken: https://gist.github.com/c35285f6563ca782e0d8.git

    Thanks. Your logs say:

    D/ch.boye.httpclientandroidlib.wire( 9033): http-outgoing-42 >> "PROPFIND /remote.php/carddav/ HTTP/1.1[\r][\n]"
    D/ch.boye.httpclientandroidlib.wire( 9033): http-outgoing-42 << "HTTP/1.1 405 Method Not Allowed[\r][\n]"
    

    so this is a server configuration issue. Please allow all required HTTP methods.



  • I’m quite a noob so please allow me this additional question. Where would I do this in my apache2 config or is this owncloud related?


  • developer

    Where would I do this in my apache2 config or is this owncloud related?

    I guess it’s an Apache option, but I can’t tell you which one (I don’t use Apache). It should be mentioned in the OwnCloud manual.



  • Hiya,

     Redirect 301 /.well-known/carddav       /remote.php/carddav/
     Redirect 301 /.well-known/caldav        /remote.php/caldav/
    

    I was bumping my head with debugging logs and trying to find out the reason for ‘Method not allowed’ and issue #12 helped me to understand I need two account and then discovered about ‘well-known’ mechanim, so I suggest to put this info as FAQ entry considering that Davdroid and ownCloud must be quite popular combo. 😉


Log in to reply