Problem connecting to radicale 0.8 / 0.9



  • While trying to connect to radicale 0.8 (which apparently doesn't know about /.well-known/*), davdroid first tries /.well-known/ using the login provided during account creation, which leads to a 404. davdroid then tries /[login]/ whih sould work, but doesn't provide the login (it tries wich what radicale interprets as "nobody"), which leads to a 401...
    While trying with radicale 0.9 (which apprently knows /.well-known), the login/redirect works fine, but the identfied collections have no name or are empty : the davdroid screen that sould apparently show the collections to sync only tells me to "select the address books / calendars" wich no item to activate/deactivate below.
    It then crashes if I hit "Next" (allowed after clicking on the title of the page).
    Everything was fine with davdroid 0.6.2, which used accounts created with 0.5. The problem occurs after upgrading the whole system.
    Nota : I like radicale because it's very lightweight. I don't plan to switch.



  • Yep, same problem for me.


  • developer



  • Yes, it seems to be related and probably the same, but I can't be 100% sure.
    Kozea/Radicale#204 references https://github.com/Kozea/Radicale/pull/198 which I don't understand though.
    (I'd rather switch back Radicale to 0.8, having DAVDroid fixed on a few phones, than hack the server with Radicale 0.9 + various commits)



  • I have the same problem, and this commit fix it.



  • As a workaround put your calendars in folder calendar.ics/ and contacts in folder addressbook.vcf/ in <radicale_path>/collections/<username>/
    For me it worked



  • The commit put me on this way. My calendar was already named calendar.ics, but was not displayed on DAVDroid discovery. I just renamed my address book to addressbook.vcf. The /.well-known/*/ URL now redirect to the correct locations, but DAVDroid stil do not display the calendars and address book in it's discovery panel. The debug log appears to be correct on Radicale side (extract below) :
    PROPFIND request at /.well-known/carddav received
    -> <current-user-principal><href>/nhuillard/addressbook.vcf/</href>
    PROPFIND request at /nhuillard/addressbook.vcf/ received
    -> <prop>CR:addressbook-home-set<href>/nhuillard/addressbook.vcf/</href>
    OPTIONS request at /nhuillard/addressbook.vcf/ received
    -> 200 OK
    PROPFIND request at /nhuillard/addressbook.vcf/ received
    with request containing empty items : <prop><CD:addressbook-description xmlns:CD="urn:ietf:params:xml:ns:carddav"/><displayname/>
    -> response containing the whole address book
    Ditto for calendar.ics.

    Seeing the empty displayname (before my first post), I tried to tweak it in nhuillard/addressbook.vcf.props, adding '{"D:displayname": "something", ...' to no avail...

    All this is with permissions control switched completely off on the Radicale side ([rights] type = None). With permission control on ([rights] type = owner_only), DAVDroid apparently do not reliably send authentication information, leading to some "Anonymous has NO read access to collection nhuillard/calendar.ics/" (I also have two other calendars, used by Tasks and Memos in Evolution, which may scramble the authentication).
    Permission control ON on Radicale also breaks Evolution (which is recognized as "Anonymous", whatever the login setting on Evolution side).



  • (the XML tags were apparently eaten above ; I may provide the full Radicale logs if needed ; just tell me where to put them)



  • https://github.com/Kozea/Radicale/issues/204 : it seems to be fixed via patching Radicale.


  • developer

    So I'll close this because it seems to be a Radicale problem. If there's anything to fix on DAVdroid side, please report it here.


Log in to reply
 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.