Ubuntu 13.04 - what changed?



  • Please help,

    I upgraded to Ubuntu 13.04 from 12.10 and Gfx Tablet doesnt work. Everything look like before (in Terminal), but when I draw on tablet in Gfx cursor on PC doesnt move. It worked perfectly on 12.10, thanks for your respond.



  • I've just got a confirmation that the app runs flawless on another 13.04... Maybe try to re-compile the source code or you've forgotten to set the input device in GIMP (set it to screen, otherwise you'll not be able to draw)?



  • I will try it again tomorrow (set it to screen) and what does it mean "re-compile the cource code". Iam beginner in Ubuntu, sorry. Thanks for your respond



  • I dont know what to do, please help me somebody:)

    1. I reinstal GFX Tablet on my Samsung Galaxy Note 10.1, with Android 4.1.2

    2. I downloaded uinput driver from your web: http://rfc2822.github.io/GfxTablet and rename this file on "networktablet"

    3. In terminal I wrote:
      martin@martin-HP-ProBook-4510s:~$ cd Stažené
      martin@martin-HP-ProBook-4510s:~/Stažené$ chmod a+x networktablet (nothing happen)
      martin@martin-HP-ProBook-4510s:~/Stažené$ sudo ./networktablet
      [sudo] password for martin:

    4. I opened GFX Tablet on my Samsung put ip of my notebook 192.168.1.36 and try to draw with pen - nothing happen - only cursor in terminal stop blinking (when it was ok - it start to write and cursor on notebook move)

    5. I opened Gimp and in Input devices I have Nework tablet and it is set to Screen

    6. When I try it again in terminal I get this:
      martin@martin-HP-ProBook-4510s:~/Stažené$ sudo ./networktablet
      error: prepare_socket(): Address already in use
      martin@martin-HP-ProBook-4510s:~/Stažené$
      I have to restart notebook

    I have Ubuntu 13.04, 64bit



  • Hello again!

    Maybe something has changes with Ubuntu 13.04 so you could build the "networktablet" driver yourself. It's not difficult, just follow these instructions:

    To get the source code via git install git on your system first: On a console/terminal write

    sudo apt-get install git
    sudo apt-get install linux-headers-generic
    git clone git://github.com/rfc2822/GfxTablet.git (this downloads the sourcecode automatically)
    cd GfxTablet
    cd driver-uinput
    make
    sudo ./networktablet

    I've attached a screenshot with the necessary steps (red bordered). These are the steps you need to do after installing git and linux-headers-generic.

    59

    after that the driver is running in the terminal.

    then open the gfxtablet app on your android. make sure it is connected to your WiFi network. then enter the ip-address of your pc in the apps settings dialog. after that you can use your pen or finger on your device and when looking into the terminal the pc should receice input data.

    *** UPDATE ***
    corrected sudo apt-get linux-headers-generic → sudo apt-get install linux-headers-generic



  • I did everything step by step, here is text (czech) from terminal with one problem

    martin@martin-HP-ProBook-4510s:~$ sudo apt-get install git
    [sudo] password for martin:
    Čtu seznamy balíků… Hotovo
    Vytváří se strom závislostí
    Čtu stavové informace… Hotovo
    Následující balíky byly nainstalovány automaticky a již nejsou potřeba:
    hal hal-info libhal-storage1 libhal1 libxine1 libxine1-bin libxine1-ffmpeg
    libxine1-misc-plugins libxine1-plugins
    Pro jejich odstranění použijte „apt-get autoremove“.
    Následující extra balíky budou instalovány:
    git-man liberror-perl
    Navrhované balíky:
    git-daemon-run git-daemon-sysvinit git-doc git-el git-arch git-cvs git-svn
    git-email git-gui gitk gitweb
    Následující NOVÉ balíky budou nainstalovány:
    git git-man liberror-perl
    0 aktualizováno, 3 nově instalováno, 0 k odstranění a 0 neaktualizováno.
    Potřebuji stáhnout 7 540 kB archivů.
    Po této operaci bude na disku použito dalších 17,2 MB.
    Chcete pokračovat [Y/n]? Y
    Mám:1 http://cz.archive.ubuntu.com/ubuntu/ raring/main liberror-perl all 0.17-1 [23,8 kB]
    Mám:2 http://cz.archive.ubuntu.com/ubuntu/ raring/main git-man all 1:1.8.1.2-1 [653 kB]
    Mám:3 http://cz.archive.ubuntu.com/ubuntu/ raring/main git amd64 1:1.8.1.2-1 [6 863 kB]
    Staženo 7 540 kB za 3s (2 231 kB/s)
    Vybírám dosud nevybraný balík liberror-perl.
    (Čtu databázi … nyní je nainstalováno 244893 souborů a adresářů.)
    Rozbaluji liberror-perl (z …/liberror-perl_0.17-1_all.deb) …
    Vybírám dosud nevybraný balík git-man.
    Rozbaluji git-man (z …/git-man_1%3a1.8.1.2-1_all.deb) …
    Vybírám dosud nevybraný balík git.
    Rozbaluji git (z …/git_1%3a1.8.1.2-1_amd64.deb) …
    Zpracování spouštěčů pro balík man-db …
    Nastavuji balík liberror-perl (0.17-1) …
    Nastavuji balík git-man (1:1.8.1.2-1) …
    Nastavuji balík git (1:1.8.1.2-1) …
    N: Ignoruji soubor „getdeb.list.bck“ v adresáři „/etc/apt/sources.list.d/“, jelikož má neplatnou příponu
    N: Ignoruji soubor „getdeb.list.bck“ v adresáři „/etc/apt/sources.list.d/“, jelikož má neplatnou příponu

    martin@martin-HP-ProBook-4510s:~$ sudo apt-get linux-headers-generic
    E: Neplatná operace linux-headers-generic

    • this is problem, it means invalid operation linux-headers-generic

    martin@martin-HP-ProBook-4510s:~$ git clone git://github.com/rfc2822/GfxTablet.git
    Cloning into 'GfxTablet'...
    remote: Counting objects: 212, done.
    remote: Compressing objects: 100% (113/113), done.
    remote: Total 212 (delta 79), reused 196 (delta 70)
    Receiving objects: 100% (212/212), 829.91 KiB | 179 KiB/s, done.
    Resolving deltas: 100% (79/79), done.
    martin@martin-HP-ProBook-4510s:~$ cd GfxTablet
    martin@martin-HP-ProBook-4510s:~/GfxTablet$ cd driver-uinput
    martin@martin-HP-ProBook-4510s:~/GfxTablet/driver-uinput$ make
    cc networktablet.c protocol.h -o networktablet
    martin@martin-HP-ProBook-4510s:~/GfxTablet/driver-uinput$ sudo ./networktablet

    it is still same, nothing happen, only cursor in terminal stop blinking, maybe I am mistake:) Thanks for your time and new proposal if its possiblle



  • For the linux-header errors
    You need to enter the command like below

    sudo apt-get install linux-headers-generic



  • OK, there is no way:(
    I did it everything again and in terminal its ok (with corrected sudo apt-get linux-headers-generic - it has already installed). My PC doesnt want receive input data.
    If I close terminal a and finish process, its necessary to restart pc if I want to try it again - in other way: error: prepare_socket(): Address already in use. In my home folder
    I have folder GFXTablet with driver-uinput now. There is networktablet - its executable and icon is like wine, double click - nothing happen, in gedit is not possible open (some errors with UTF-8)
    In gimp I can see network tablet and some other - everything sets on screen
    Thanks a lot for your time and help



  • seems that the compinling worked. you've to close the terminal by pressing CTRL+C to close it, otherwise it still continues running.

    it seems that there is some kind of firewall (or the router) or so blocking the transmission of the data... be sure that port 40118 is open and not blocked...



  • Hi,
    I went to my router - Zyxel (NBG-417N) in NAT/Application and set the port 40118 (as well as in Advanced). Iam not sure if I do it well. I dont know about any firewall on my Ubuntu, I did never install it.

    NOW DOES IT WORK - THANKS A LOT, YOU ARE GREAT:)

    welcome to zyxel nbg-417n nbg-417n - mozilla firefox 16 5 2013 204426