Build with Gradle 2.0



  • Unfortunately I'm unable to build DavDroid with Gradle 2.0 which is the default in my operating system. Is there any alternative to downgrading it?

    onny@onny ~/davdroid-upstream (git)-[master] % gradle build
    
    FAILURE: Build failed with an exception.
    
    * Where:
    Build file '/home/onny/davdroid-upstream/build.gradle' line: 19
    
    * What went wrong:
    A problem occurred evaluating root project 'davdroid-upstream'.
    > Gradle version 1.10 is required. Current version is 2.0. If using the gradle wrapper, try editing the distributionUrl in /home/onny/davdroid-upstream/gradle/wrapper/gradle-wrapper.properties to gradle-1.10-all.zip
    
    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
    
    BUILD FAILED
    

    Best regards,
    Jonas


  • developer

    I don't know/use Gradle. To build DAVdroid, use ant or Eclipse.



  • @onny: Not sure what app you are using that ships an internal davdroid, but you can tell them to use the Gradle Wrapper. Having that wrapper in the repository the appropriate gradle version is downloaded automatically. (so gradle is used, but doesn't have to be installed)


  • developer

    Will be migrated to the gradle build system soon in order to work with Android Studio.


  • developer

    DAVdroid does now use gradle.


Log in to reply
 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.