Adding an account stopped working with DAViCal since DAVdroid 0.6.



  • The last version before that in F-Droid still works. But with 0.6 DAVdroid complains about an invalid DAV response. Unfortunately the debug logs are so extensive that I can’t find exactly why that is.

    Try to add a new account. Already added ones seem to continue working, even after the update to 0.6…

    If you can’t reproduce it, tell me, and I can send you those extensive debug logs. :)
    But please first try to reproduce it without them, because it will be a lot of work to make sure the logs are anonymized.


  • developer

    We have tested DAVdroid 0.6 with Baikal, too. Please send the bug reports to play@bitfire.at if you want to keep them confidential.


  • developer

    Are you sure that it "doesn't work" anymore? Maybe the password is just wrong. In this case, 0.6 shows "Neither CalDAV nor CardDAV available" instead of the HTTP error message; this is fixed with 0.6.1.



  • Hey, I’m a developer myself and I know how annoying it can be when people say vague things like “doesn’t work”. Rest assured that it’s nothing simple or obvious, as I went through all those things myself for eight hours, including trying to filter something useful out of the DAVdroid and apache logs and even analyzing the network packets, before I gave up and posted here.

    The facts are these:
    • I tried it with 0.6, and even though KDE/Akonadi/Kontact and Thunderbird/Lightning/SOGo worked flawlessly, DAVdroid did not. I checked for typos, any kind of connection problem, tried every thinkable path, mod_rewrite, apache config, DAViCal config and security grant/setting.
    • Somebody on IRC said the exact same version of both DAVdroid and DAViCal worked for him. But when now creating a new sync, he got the same “Invalid CalDAV response” error that I do. So I asked him if he had originally configured it back before 0.6 was out, and he said he did… around March or April.
    • So I went through the old versions of DAVdroid available in F-Droid. And while all the older ones failed due to being unable to support TLS 1.2 or similar TLS problems, I finally got to create the syncs, and it to function perfectly with 0.5.14-alpha.
    • The person I spoke to on IRC confirmed that it kept working when going back to 0.6, provided one keeps the old sync config. So the problem only occurs when creating new syncs.

    All this makes it really clear that it’s a kind of bug in 0.6.

    I will try 0.6.1 or later as soon as it’s available though F-Droid. (I’m rather poor right now. Sorry. All I can offer is a place to sleep or where to find nice things in my city that no tour guide will ever cover. :)
    But it’s definitely not a password problem.


  • developer

    All this makes it really clear that it’s a kind of bug in 0.6.

    So please post logs when you find some time, so that we can identify the reason soon. :)



  • Okay, this is the output of a

    adb logcat | egrep '^([EW]/)|(./davdroid)|(./ch.boye)'
    

    during at least one attempt to create a sync:

    http://pastebin.com/y5yiHdGG

    Unfortunately it seems adb logcat simply dumps everything and without any time stamps too.
    I hope I could filter out all the private data. This paste URL will be gone, 1 month from now.


  • developer

    It seems like this is because DAVdroid 0.6 checks the capabilities on the principal URL and not on the address book / calendar URL. However, your server reports that the principal (/caldav.php/myname/) doesn't support calendars while the exact URL (/caldav.php/myname/Calendar/) does.

    I'll think about how this could be resolved.


  • developer

    OK, should be fixed with 0.6.1.



  • Yeah! :)
    I wonder though it that is a bug in DAViCal too… But I know nothing about that.

    Thank you very much!


  • developer

    I wonder though it that is a bug in DAViCal too… But I know nothing about that.

    No, it's just a rare configuration that I haven't seen at other servers/services, but it's perfectly OK to do so.


Log in to reply
 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.