• Hello!
    After last update I can’t add account. Show “I/O error http protocol not supported”

  • developer

    Can’t reproduce that here, HTTP is working (tried with OwnCloud demo server from http://davdroid.bitfire.at/configuration). Please give a detailed error description, including steps to reproduce.

  • When I try to add account, davdroid actually don’t try to connect to server, it immediately show “I/O error http protocol not supported” after I pressed arrow symbol, seems it is android problem. My phone is Sony ZL with 4.3 Android. Before update everything worked ok!

  • developer

    Confirmed for

  • Hi, try to debug it a little. Please consider upgrading the build system to maven or something simillar, it will make things much easier to debug source code even for attached libraries.

    I am unable to attach a patch; just copied & pasted it here, its single line of code + import:

    class: at.bitfire.davdroid.webdav.DavHttpClient

    action – register socket factory:

    	socketFactoryRegistry =	RegistryBuilder.<ConnectionSocketFactory> create()
    			.register("https", TlsSniSocketFactory.INSTANCE)
                .register("http", PlainConnectionSocketFactory.getSocketFactory())


    Also consider printing full stacktraces from 3rd party libs.

    EDIT: 1st time on GitHub – just created a pull request.

Similar topics