Can't configure DAVDroid account with Synology



  • I don’t have a lot of time, but I will first have to run some test on other clients. It’s an account with access to WebDav/CalDav on my Syno you need, right ? If so, no problem. I’ll do my test, and then, I’ll send it to you.



  • Hi,
    Any help is welcome, but don’t feel rushed by me. I’m using your issue to add information about mine.

    I was checking whether my issue was already posted before writing a new one. Yours seemed similar due to the error message.
    Since rfc2822 was asking for more information and a test account, I thought it might be helpfull to make one for my issue as well.
    Maybe our issues are related and my test account can help solving them.



  • Hi,

    Little update 🙂
    Sorry, it’s a bit late, but I didn’t had time to do it before.

    I ran some test, and it’s working fine on Thunderbird (with Lightning), but I still got the same error with DavDroid.


  • developer

    After testing a Synology device, I found out that for some reason, the current-user-principal is not returned, so that auto-detection of resources is not possible (and DAVdroid only supports resources which are automatically detectable).

    > PROPFIND /CalDav/Testuser/ HTTP/1.1
    > Authorization: Basic XXXXXX
    > User-Agent: curl/7.32.0
    > Host: xxxxxxx:5006
    > Accept: */*
    > Depth: 0
    > Content-Length: 73
    > Content-Type: application/x-www-form-urlencoded
    > 
    * upload completely sent off: 73 out of 73 bytes
    < HTTP/1.1 207 Multi-Status
    < Date: Sat, 29 Mar 2014 21:17:51 GMT
    * Server Apache is not blacklisted
    < Server: Apache
    < Content-Length: 344
    < Content-Type: application/xml; charset="utf-8"
    < 
    <?xml version="1.0" encoding="utf-8"?>
    <D:multistatus xmlns:D="DAV:" xmlns:ns0="DAV:">
    <D:response xmlns:lp1="DAV:">
    <D:href>/CalDav/Testuser/</D:href>
    <D:propstat>
    <D:prop>
    <lp1:current-user-principal><D:unauthenticated/></lp1:current-user-principal>
    </D:prop>
    <D:status>HTTP/1.1 200 OK</D:status>
    </D:propstat>
    </D:response>
    </D:multistatus>
    

    I have looked for a way to report/discuss that with Synology, but I couldn’t find any way to contact them electronically except the contact form, which I can’t use because I actually don’t have an own Synology device and can’t register without serial number etc.

    Follow up: https://twitter.com/davdroidapp/status/450018678957158400 & waiting for a response…


  • developer

    I have also read that it is possible to install OwnCloud (maybe even other CalDAV/CardDAV servers?) to Synology devices, which would work around this problem.


  • developer

    Also see https://twitter.com/davdroidapp/status/471652913082023936

    Closing this for now, please report further problems directly to Synology.



  • Any news following this issue ? Did you received any feedback from Synology?
    I’m actually in a similar situation: bought the davdroid app but can’t get it working due to this Synology issue.

    Regards,


  • developer

    DAVdroid 0.6.12 now supports Synology, we have changed the detection code so that it doesn’t require current-user-principal support.

    Configuration details: https://davdroid.bitfire.at/configuration



  • Thanks a lot, it will be useful 🙂

    I wish Synology had corrected the bug on their side, though.



  • @TheDoctorII yes, would have been a lot easier if they did…
    @henry-nicolas Can you maybe test the new version 0.6.12 (see https://davdroid.bitfire.at/configuration for configuration details) and tell us if it works for you?



Similar topics