DAVx5 tries to sync tasks when there are no tasks app ?

  • I found a weird behaviour and think I identified the bug.

    Sometimes, seemingly at random, but often a few moments after disabling Plane mode, I am notified that DAVx5 failed to sync. The failure is normal because my server is not running at that time, but the sync trial should not happen because the sync intervals for my agenda and calendars are set to Manually.

    My CalDAV agendas have tasks enabled, but I don’t use this feature currently, so I had not installed any tasks app on my phone. As a consequence DAVx5 hides the setting for tasks sync interval, in the parameters page of my DAV account (opened with the gear icon). After installing such an app, the setting became accessible and I found it was like “240 minutes or at local change”. So maybe DAVx5 tried to sync my agendas because of this?

    Now that I’ve set this interval to Manually, I expect the spurious syncs not to happen anymore. However, the phenomenon being quite erratic (I’ve found no reliable steps-to-reproduce) it will take a long time to be sure the problem is solved.

  • developer


    Thanks for the report. If you find steps to reproduce so that I can try, please let us know.

Similar topics

  • 7
  • 12
  • 2