Not syncing all of Google Calendar ics subscription

  • This post is deleted!
  • developer


    I don’t understand your setup. Do you use ICSx5 or DAVx5?

    Please provide exact steps (beginning with an empty DAVx5/ICSx5) to reproduce the problem so that I can have a look.

  • @rfc2822 Thank you for the reply

    I use DavX5 to sync to a google calendar. That calendar has an ics calendar subscription. All events from the ics calendar are appearing on the google calendar.

    I’ve followed the set up instructions show here…

    …and use an google app password as I have 2 step verifcation.

    All contacts and calendar events (except those ics calendar events until April 2022) are synced correctly with my android calendar app (Simple Calendar 5.2.0)

    Does that give you enough info?

  • developer

    @rasta-dog Thanks, I could try with these steps 🙂

    However I can’t reproduce the problem. All events are shown without problem:


    Is there a specific event which you’re missing?

  • This post is deleted!
  • developer

    @rasta-dog Very strange. There is no such flag in DAVx⁵.

    Did you try another calendar client with the same URL?

    You can

    1. unselect the calendar, force sync,
    2. enable DAVx⁵ verbose logs (in DAVx⁵ app settings),
    3. enable the calendar and force sync again.

    Then you can see in the logs what’s happening and whether those events are received and how they’re processed.

  • @rfc2822 I think I’ve sorted it out now.

    I decided to start afresh, wipe the tablet and reinstall everything. I decided to do that because I decided it was possible that the local android calendar storage was corrupt/broken.

    I’d tried another calendar app but the same thing happened.

    I also tried a calendar app (OneCalendar) that has its own sync tools, and that worked. So that lead me to suspect that the tablet’s own calendar database was the problem.

    I’d done as you suggested above and in the debug log I saw 20 messages like this,

    2ddee1de-94e2-4d01-be8e-9cd87137121f.ics has not been changed on server (ETag still 63768232659)

    So I guessed those messages related to my missing calendar events and that the local (android?) calendar storage database contains some reference that indicates the event is already stored so it’s not being sync’ed (as you’d expect). So this again suggested to me that the calendar storage was somehow corrupted/broken.

    The only way I could see to fix that was wipe and start again 🙂

  • I’m giving up because I have no idea what’s happening. I wiped my tablet and reinstalled everything - same thing happens. I restored a back up from last month but again the same happens.

    I suspect it’s something to do with my shared calendar on the google account. I’ll just have to put up with it, it only effects from the single ics calendar and only up until April 2022.

Similar topics