How to get all previously ignored events back in the calendar?


  • All is running fine including the syncing between the server and several devices. And it has been running fine for months.

    It was only recently that I found out about the “Past event time limit” being set to the default 90 days.

    For my business I need to go back a little over a year, and check which appointments I had when, where and with whom.

    How do I get that kind of data back in my calendar, even if it is only temporary?

    I have set the “Past event time limit” to 0 but that does not seem to have any effect. I understand the reasons for not having the value set to 0 all the time (lots of data, lots of traffic with every sync), but having access to those “ignored events” sure comes in handy now.

    Kind regards,

    D.

  • developer

    @donquishot Hi, 0 means: don’t sync events in the past (0 days from now), but only future events. See here for details and what settings are possible: https://www.davx5.com/manual/settings.html#caldav

    Does that help?


  • @rfc2822

    Sorry, my mistake. I meant to say that I left that setting with an empty value and not 0. The empty value did not get all events in the past synced. I could try of course filling in a value of 365 and see if that brings up the requested data/events of the past ‘year’.

  • developer

    @donquishot said in How to get all previously ignored events back in the calendar?:

    @rfc2822

    Sorry, my mistake. I meant to say that I left that setting with an empty value and not 0. The empty value did not get all events in the past synced. I could try of course filling in a value of 365 and see if that brings up the requested data/events of the past ‘year’.

    The empty value should work. You can try to

    1. set it to empty
    2. unselect the calendar in DAVx5
    3. force sync
    4. select the calendar again
    5. force sync again

    or try with 365 days yes… generally I always recommend to usage a certain value. 365 or even 1000 days may be ok, but no value doesn’t scale.


  • @rfc2822 Thank you for the solution above. I’ve set the value to 730 ( 2 years) and all is well. And thanks again for the swift replies. Highly appreciated.

    D.

Similar topics

  • 4
  • 4
  • 2