DAVx5 does not show local calendar

  • Hello,

    Thank you for providing a solution to sync calendars and other data to various services.

    It all works fine, except that my local calendar does not show in the DAVx5 app.

    I am using Android 9 on a Sony phone. I am trying to sync my local calendar (not a Google calendar) to NextCloud. The calendars that I created in NextCloud all show in the app, but not the local one.

    I have been reading a lot, but seem to miss something. What I have tried:

    • Restarted my phone
    • Reinstalled apps in various orders
    • Excluded DAVx5 and the local calendar from battery saving
    • Triple-checked whether DAVx5 has the Calendar permission. It has.
    • Refreshed DAVx5 several times (both by the Refresh button and the manual refresh by swiping from the top down)

    What might I be missing?

    Thank you in advance for your help.

  • developer


    @choti Did you check the calendar in DAVx5 (check box on the lieft side)?

    Did you try another calendar app?

  • admin

    @choti The local calendar on the device does not get synced to nextcloud automatically. If you want these events to come to your NC you need to export that calendar events first, and then import them back into the DAVx5 accounts calendar (that is already connected with your NC). You can use ical Import/Export for this. In order not to mix it, please create an empty new calendar first on your Nextcloud (refresh the list in DAVx5 to see it) and import the events into this new calendar. When the next sync happened the events should show up in NC in the new calendar. If that worked you can delete the local calendar from the device or disable it. Until the happening of the last event you can keep both NC calendars, and after that time you could delete it and continue with the original one, so that you only have to manage one calendar. Does that help?

  • @devvv4ever It does. Thank you. This was way more comprehensive than I expected .Appreciate that. Didn’t know about iCal Import/Export. Seems simple enough.

    Thank you for the assistance! 🙂

Similar topics