• Hi everyone.
    For a year now I’ve discontinued every google app (mail, mdr, photos and all) to pass everything on my synology nas.
    I installed among other things the calendar application (caldav server), after a bit of testing to understand the ports I was able to synchronize the calendar on the nas with the calendar of my macbook and my android phone (via davx5, which i payed 5€).
    Everything worked perfectly until a couple of weeks ago, using https://myserver.synology.me:port/caldav/utent/ as the address.

    Now I have serious syncing problems. The events that I enter (both from PC and smartphone) are found on the caldav server (entering through the dedicated gui), but not on the other device (in other words, if I enter an event on the calendar from mac, I see it on mac and on the server but not on android… if I enter it from android, I see it on android, on the server but not on mac…but every event is correctly on nas calendar).
    I really tried everything and every kind of apps.
    I don’t think it’s a port problem, since both davx5 and the calendar on mac access it correctly, and since the events I enter are actually seen on the server. I don’t understand what could have happened and I’m going crazy (I’ve tried using different calendar apps on both android and mac…but no difference). It’s like in “write” it works but in “read” it doesn’t.
    I use Huawei Mate 20 pro and make all for not having problems with battery optimization, it works in backgroud and everything…

    What could have happened, given that everything worked until a few weeks ago and I haven’t changed anything?
    I use it heavily for my work and I’m having serious problems.

    In the hope that someone can give me some advice!

  • admin

    @redduzzo This sounds like a problem of the server not updating the e-tag of the resource that is synced to the server. If the e-tag does not get updated, the other device that tries to sync will think that there are no changes because the e-tag didn’t change and discards a sync. often e-tags get filtered through a firewall, or router. maybe that helps in finding the cause of the problem.

  • @devvv4ever Thanks!
    How can i try to solve this e-tag problem?
    Maybe uninstalling and re-installing calendar on synology?
    How can i backup all calendars, as they are fundamentals for my work?

Similar topics

  • 3
  • 13
  • 1