No compatible task app found although OpenTask and Task.org installed



  • Since yesterday or the day before I am facing the problem that my tasks on my mobile phone will not get synchronized with my CalDAV/CardDAV server (but Calenders and Contact sync is still working).

    When opening DAVx5 app on my mobile phone a welcome screen appears and after submitting “Next” a screen appears to chose a task app. I have never seen this before. If I want to chose my already existing (and in the past working) OpenTask app, only the Play Store app will be opened but OpenTask is not chosen in DAVx5. Same is when choosing and installing Task.org app (I have tried this to today for verification reasons).

    When checking the settings in DAVx5, in “Integration” section, for Task app it is stated “No compatible task app found”.

    Both apps, DAVx5 and OpenTasks are not impeded by any battery optimization, permissions are also set for Tasks. Running Android 11 with security update from 05.10.2020 on a Pixel 3 phone.
    Running DAVx5 in version 3.3.5-gplay (303050000).


  • developer

    Hi,

    Can you please post DAVx5 debug info? (DAVx5 / App settings / Debug info / Share)



  • I have sent you my debug info using the secure support form of www.davx5.com due to personal data within the debug information.

    Hope this will help analyzing the issue. Many thanks in advance!



  • Completly deinstalled DAVx5 and OpenTask on my phone and did install both again. Then, it worked again. Problem solved 🙂


  • developer

    @bachmi Thanks for the update! It seems to be some problem with Android 11 package visibility (DAVx5 must not see OpenTasks and tasks.org although visibility is declared and the packages are there). Good to know that re-installing helps.



  • Beware! I uninstalled DAVx5, reinstalled it, connected it back to NextCloud and all of my local tasks were deleted which were not already synced to NextCloud. Pretty annoying, I must say. I am also on Android 11.


  • developer

    Does this still happen with DAVx⁵ 3.3.6?



  • I don’t know. I am still on 3.3.5-gplay. Should I wait for the update to 3.3.6 before I fix the problem for other people?


  • developer

    @CaveDave We have added a possible workaround to 3.3.6, so it would be very interesting whether this really works around the problem or not. I’ll send the APK over email!



  • @rfc2822 My wife didn’t have the issue like I did for some reason. 🤷 She has a Pixel 4 and I have a Pixel 2. I don’t know if that would have made a difference.


  • admin

    Just sent the APK. Android 11 introduced new “awesome” features – wohohohoo – like this package visibility, but it seems due to a bug in Android 11 the visbility of our declared providers gets lost after a few days. Now we changed it to the package names instead of the providers we want to see - hopefully this fixes the problem…



Similar topics