No task synchronisation despite granted permissions

  • Hi all,

    I have just done a a clean install of LineageOS 17.1 (LineageOS for microG, 2020-09-21,
    Setting up DAVx5 worked fine - except the permission considering tasks.
    I installed OpenTasks (in German “Aufgaben”) during the setup process of DAVx5.

    I then tried to grant the relevant permissions:

    The first switch will not “stick” to activated, it will always reset to the state seen in the screenshot.

    This leads to the following:

    I then went into the system’s permission settings for DAVx5 which looks like this:

    As you can see all permissions have been granted.
    Looking at the additional permission reveals:

    So DAVx5 also has the permission for tasks.

    Let’s look at the permissions for OpenTasks:

    OpenTasks also has been granted all permissions.
    Also looking at additional permissions here we see:

    Looks wonderful, right?
    But it does not work.
    Not so wonderful.

    Looking at the permission overview for tasks we see at first:

    Huh? Confusing.
    If I activate “Show system apps” in the burger menu we get:

    Oh, there they are. But DAVx5 and OpenTasks are no system apps.

    And still task synchronisation does not work.
    I did not have this problem in previous builds of LOS 16 and 17.1, just now in this fresh install - which I find especially irritating.

    I would be grateful for any ideas.

    Best regards

  • Hi Laguja,

    I have the exact same situation on my Samsung S10e (no LineageOS).

    Davx5 stopped last thursday syncing tasks all of a sudden… I reinstalled Davx5, Opentasks, updated my Nextcloud, updated Samsung firmware… no change at all.

    Would be great if anyone could help us with this.

  • Ok after days of trying I just fixed it.

    What I did:

    • install app
    • let Davx5 sync with, not with Opentasks
    • give permissions when asked and sync in Davx5
    • won’t sync with a free account, but that’s ok
    • in Davx5, now switch back to Opentasks
    • sync Davx5 and Opentasks (hey, my tasks appear!)

Similar topics