IOException error while syncing address book

  • I’m getting a ‘’ error when trying to sync my address book, or more specifically, one particular contact within it.

    The log output is available here.

    I’ve tried removing and re-syncing the address book, deleting and re-adding the contact, and editing fields within the contact to try and determine the problem field, all of which haven’t worked.

    I have found this StackOverflow article that talks about needing to close the connection when using OkHttp3, and I can’t find that particular function call within HttpClient.kt.

  • developer unexpected end of stream on
    at okhttp3.internal.http1.Http1ExchangeCodec.readResponseHeaders(Http1ExchangeCodec.kt:18)

    Caused by: \n not found: limit=0 content=…
    at okio.RealBufferedSource.readUtf8LineStrict(RealBufferedSource.kt:23)
    at okhttp3.internal.http1.HeadersReader.readLine(HeadersReader.kt:1)

    The problem is that your server interrupts the stream while sending the HTTP headers (an \n would be expected, but there was something elese). What server do you use? It seems to run on port 2080, so you should usually proxy it behind a real Web server.

  • Hi @rfc2822 ,

    Unfortunately I don’t run the server, it’s run by my hosting provider. It’s using cPanel, so I suspect the use of port 2080 is something that cPanel controls.

    I can open a support ticket with my provider - is there anything that I can tell them that might be useful?

Similar topics

  • 2
  • 7
  • 3