New Nextcloud server - Error 405 Propfind not allowed



  • Hi all,
    This is a topic that has been discussed several times before on this forum, but none of the solutions offered in previous threads have helped me so far…

    I’ve just finished installing the latest version of Nextcloud on my Raspberry Pi 3 (following this excellent tutorial). My Apache2 server is also newly installed, latest packages etc, haven’t changed anything.

    I can access the Nextcloud interface perfectly through my various computers locally, and it seems to be working just fine. For now I haven’t enabled port forwarding on my router, because it’s a grumpy old router and I’m about to move out of this appartment soon; I’d just like to sync my phone and server when I’m at home.

    Trying to use DAVx5 (latest version) on my OnePlus2 to connect to Nextcloud, by creating a new account on DAVx5, I get the error: “Cannot find a CalDAV or CardDAV service”. The log speaks of an “Error 405: PROPFIND not being allowed.” Please see the full log here.

    The local network is connected to the internet. Is this issue linked with port forwarding? Or do I need to tweak my Apache server to allow PROPFIND somehow?

    All advice will be warmly appreciated!


  • developer

    Hi,

    According to the logs, you tried https://yourserver/nextcloud/ as Base URL. You have to use the one from https://www.davx5.com/tested-with/nextcloud (in your case, https://yourserver/nextcloud/remote.php/dav) or configure well-known URLs.

    Does that help?



  • @rfc2822 Many thanks, yes I forgot about that base URL setting somehow. Sorry for the basic question 😊



Similar topics