One of three calenders could not be synchronized after the last two updates 3.1 and 3.1.1

  • developer


    Do you use the WebDAV package? Can you maybe provide a test account? We can’t reproduce this with our Synology DSM.

  • The funny thing is, that three other accounts work, even with the new versions. I have already tried to setup this account brand new, but anything changes…and yes I use the webdav server from DS.
    The only thing which differs is, that this special account is also used by my family with apple devices…the others not. Did this might lead to an issue?

  • developer

    I don’t know; can absolutely be the case. The problem is that when we can’t reproduce the problem, we can’t take a look. And a server sending 404 (like in your exception info) is normally a server problem and not a client problem. Also, we didn’t change anything between 3.0 and 3.1 that should cause any changes in that sync behavior.

  • Hi, I have tried a lot today:

    1. Created a new calendar --> it works
    2. copied the calendar files from the old one in the new calendar --> doesn’t work
    3. deleted the app with every data from my mobile and recreated everything --> calendar doesn’t work
    4. checked the calendar with outlook --> it works
    5. reinstalled the old version 2.6.5 --> it works

    Now I am lost…

  • developer

    If you can reproduce it somehow and maybe even provide a test account, please let us know and/or send an email to so that I can give a try. When I can reproduce the problem, I can have a look at it.

  • I gave it another try and connected the calendar of the iphone with xdav and it works.
    The next funny thing is: during another test I reset the cache of my android calendar. During this test davx 3.1.1 works for 2h (sync interval 15min), then the error occurred again.
    To make sure this was just a chance, I did the test twice again…the error occurred now every time instantly…

    I have no idea how to reproduce the error. It only occurs with one of my calendars and with davx 3.1 and 3.1.1, with 2.6.5 it works fine.


  • So today I updated to 3.2. The issue occurred again but when I manually start syncing it works. This issue is then fixed until an iPhone user makes an entry to this calendar. Then the upfront mention behavior occurred again…and this its reproducible.

  • developer

    So after someone uses an iPhone with this calendar, the server returns 404? Is this correct?

  • Yes. Everytime someone is using an iphone and changes something, I got 404 back. After some tries (at least 3) it works and there is no more error until somebody with an iphone is changing something again.

  • developer

    Then this really sounds like it’s not related to DAVx5 and I unfortunately don’t know whats going wrong between iPhone and your server…

Similar topics