couldn't find caldav or carddav service



  • Hi
    I would really appreciate your help, I’m lost. I’ve been trying for hours and days to make the DAVx5 app work with Synology on my BlackBerry KeyOne (Android 8)… I’ve tried EVERYTHING, read all the threads, manual, restarted the phone several times, uninstalled the app at least ten times, checked phone settings, even searched for and installed an old version of DavDroid. But absolutely nothing works… 😞 Neither caldav nor carddav I always get the message “couldn’t find caldav or carddav service”. On Thunderbird all worked fine at the first attempt, so it can’t be Synology I think? It must be something in my phone or with the app or there is some hidden feature I haven’t been able to find?
    I really hope someone can help, thanks for looking into it already, I attached a couple of logs.davx5-info.txt davx5-info (1).txt davx5-info (2).txt


  • developer

    Hi,

    2020-06-10 14:39:40 2615 [HttpClient] <-- HTTP FAILED: java.net.UnknownHostException: Unable to resolve host "monolith": No address associated with hostname
    2020-06-10 14:39:40 2615 [ui.setup.DavResourceFinder] PROPFIND/OPTIONS on user-given URL failed
    EXCEPTION java.net.UnknownHostException: Unable to resolve host "monolith": No address associated with hostname
    	at java.net.Inet6AddressImpl.lookupHostByName(Inet6AddressImpl.java:141)
    	at java.net.Inet6AddressImpl.lookupAllHostAddr(Inet6AddressImpl.java:90)
    	at java.net.InetAddress.getAllByName(InetAddress.java:787)
    

    DAVx5 can’t resolve “monolith” in your network. Can you access http://monolith:5000 in your Android browser?



  • Hi
    Many thanks for your reply! I tested that and I found that I actually couldn’t access it (no IP address) from my Android browser which is strange because anywhere else (home PC, Laptop, PC at work, Thunderbird…) I’ve always had access.
    So I looked up the NAS’s IP address on my modem and when I use the IP itself in DAVx5 it worked!! So I assume this has something to do with static/dynamic IP addresses, what do you think? I assumed my NAS has a static address because I can always login with the same address (monolith:5000) but I guess I was just lucky that when I updated it, it received the same address after restart. I bought it half a year ago…
    So long story short, I’ll have to make sure that this address is static and it will keep on working/synchronizing or do you think the problem lies somewhere else?
    Your help is highly appreciated, thanks again!


Log in to reply
 

Similar topics

  • 3
  • 7
  • 14