Event reminder (alarm) synch Android & SOGo partially working

  • Hi All
    although we have been using DAVx5 for quite some time now (appreciate all the work, it’s an excellent tool and we recommend it to all our customers who are using SOGo or Nextcloud backends) successfully for Caldav/Carddav integration, I have recently found an issue.
    I am new here in the forums and have searched before posting but in case it is a known issue or has been asked before and I did not find it, please bear with me.

    My set up is Android 10 with all updates running on a Nokia 7 Plus (upgraded from Android 9 some weeks ago), DAVx5 latest version 2.6.5-gplay. Server backend is SOGo version 4.3.0.
    Our preferred Android calendar app is aCalendar+ which I find to offer the best event & task integration for Caldav based calendars but for testing purposes, I am also using other calendar apps like “SimpleCalendar”, downloaded from F-Droid.
    BTW, on the laptop side, Thunderbird/Lightning integrates into this backend also very well.
    The issue seems to be when creating a new calendar entry on the mobile side, setting an alarm notification for let’s say 15 mins prior to the event, this will synch nicely (via DAVx5) to the SOGo backend. So the Android calendar app shows that there is an alarm associated and the notification will pop up as expected.
    The SOGo calendar entry also shows that 15 min alarm as “Send appointment notifications” accordingly.
    If instead, I create an event in SOGo with an alarm/notification, the event itself will nicely be synchronised to the phone and will show up in the calendar app according to the chosen DAVx5 synch intervall (or by manual synch if impatient) and apart from the missing alarm, all other details for that event are in synch, including the recently added event category synch.

    I hope this is the right place to start asking this question.


  • Answering myself … feeling a bit stupid (☹ )…
    I found that I had disabled a calendar property at the SOGo backend called “Show Alarms” which was me misunderstanding its results. I thought it was to prevent alarm/notification pop ups when using the SOGo web interface. It turned out to be much more.
    Once re-enabled everything works with two way synch as expected.
    Sorry for the noise.

  • developer

    Thanks for the update and information!

Similar topics