Cannot authenticate with app password in Nextcloud account / regular password works



  • I have been trying to set up an account with an Nextcloud instance in DAVx5 using an individual app password, such as
    fT2er-5TpYm-fnQHK-yy7BA-SmkeX
    which is generated by the service itself.

    Unfortunately this does not work:

    <s:exception>Sabre\DAV\Exception\NotAuthenticated</s:exception>
    <s:message>No public access to this resource., Username or password was incorrect, No ‘Authorization: Bearer’ header found. Either the client didn’t send one, or the server is mis-configured, Username or password was incorrect</s:message>
    </d:error>

    If I use the regular password everything works out fine.

    I have set up Thunderbird/Cardbook using an app password which caused no problems whatsoever.

    I would be grateful for any help you can give.


  • developer

    Hello,

    Then it’s probably not the right username (email vs user name?)/app password (extra space in copy/paste? revoked by mistake?), and/or there is a server error. The way you have described is correct and works here.


  • developer



  • Hi,

    thanks for the swift reply.

    @rfc2822

    it’s probably not the right username (email vs user name?)/app password (extra space in copy/paste? revoked by mistake?), and/or there is a server error.

    I’m sure all the credentials were correct since I did a direct copy-and-paste from the web-interface and also double checked them.

    Especially confusing was the fact that when swapping the app password for the regular one made all the difference and the account was created as expected.

    It all came down to the app specific password not being accepted.

    you can also install the Nextcloud app and then use Login flow to generate/use the app password automatically. Does that work?

    Well, I did that and it worked out fine.
    I removed the account in the Nextcloud app and also revoked access for it in the web interface but kept the DAVx5 account.
    This still works fine.

    Here where it gets weird: trying to create an account as before, i. e. using an app password, now also works. 😮

    I cannot say what “blockage” using the Nextcloud Login flow freed up but everything seems to be in working order now.
    I’ll keep an eye on it, though.

    Thank you for you assistance.


  • developer

    I see. Well I don’t know what was wrong but because it now works as expected, I’ll mark this as solved 🙂


Log in to reply
 

Similar topics

  • 3
  • 11
  • 20