Change "past event time limit" won't change anything


  • I synced my calendar with the default settings first. Then I noticed the past 90 day setting and changed it to “empty” so every event will be synced. But this doesn’t change anything 😞 There is still no event more then 90 days old on my android phone, but on the caldav server i see all the old events.
    How can i force syncing of old events?

  • developer

    The new setting should apply as soon as there’s any new or updated event (remote or locally). Does that help?

    But you’re right, the setting should apply immediately.


  • Unfortunately no 😞

    1. I added two more events (one in the past / one in the future) in my local Thunderbird/Lightning Calendar. They got synced to my caldav instance without a problem

    2. I manually started the sync progress on my phone with davx5 … but nothing changed on my phone 😞

    3. Then I added a event in the past on my phone and started a manually sync with davx … and they got synced with my caldav instance without a problem (and even with Thunderbird/Lighning).

    But still, the other older events are not on my phone 😞


  • Hi.
    I have the same problem.
    After several month with the default setting I changed this setting today to sync also older events. (It is now blank) I am syncing against a Nextcloud 18.0.1. On Android I am using aCalendar and default Google Kalender App. None of them showing events older than 90 days even after several syncs and phone restart.
    On PC with Thunderbird all events are shown correctly.
    😕
    Debug information says for the Nextcloud calendar:
    Time range (past days): null

  • admin

    @Olfelm You can try to deselect the calendar, press sync, then select it again. Does it work then?


  • @devvv4ever I tried it and it works! Of course I had to sync again after switch the calendar on again. Now I have all my events. Thank you very much. 😁

  • admin

    Perfect 😉


  • Yes … works for me too … thx alot, wife is happy again 🙂


  • Hello, got the same problem. Fixed it the same way (by unselecting said calendar, sync, reselecting it and sync again).

    Obviously it’s a bug in DAVx5. So one question remains: will it be fixed? It doesn’t seem that your issue tracking is public, there’s only this forum so I suppose it’s the right place to announce bug fixing.

  • admin

    @phneutre Hi, yes this is the right place for everything - even for reporting possible bugs or issues 😉

    However I just tried it and it works as expected. The sync will be scheduled immideately after you either change the value or remove the value. As long as the orange bar moving around above your calendar list the sync is running. When removing the value so that the “Past time event limit” option is empty you need to give the sync some time to complete, because it then needs to sync your all your events of all calendars - that can be a lot of data and the device needs to process it, too.

Similar topics