Davx5 don't aquire Read Task permission => error on task sync

  • Hi,

    After several install / re-install of davx5 on my xiaomi / mi11 I always have the same problem :

    davx5 don’t explicitly ask for task read permission (but ok with calendar read) . I have to go in settings/…/other and select ‘enable’ for task. The parameter stay after reboot but task don’t sync. No error message from davx app but explicit error message from settings/accounts/davx5/sync : error on syncing task … (in french on my phone)
    In the verbose log, i can find that davx5 DON’T have task read permission, unlike what is notified in the settings
    Did you notice English is not my native langage ?

    verbose log

    best regards,

  • developer


    Did you try uninstall DAVx⁵ and OpenTasks before installing/trying again?

  • Hello,

    Thank you for your answer.
    I’ve immediatly try to :
    uninstall davx5 and opentask - reboot - reinstall from fdroid - add my nextcloud account

    Same problem with same log : every permission granted BUT READ_Task

    I notice that the permission I accepted is granted (write Task) but the denied permission (read_task) can’t be accepted or not in the system (no asking pop-up and no parameter in settings )

    Thank you for looking at my problem.


  • developer

    @psklb I see. Unfortunately, I don’t have any idea why READ_TASKS can’t be granted on your system, nor have I ever seen this reported by someone else. So I think it’s some glitch on your system… 😐

  • Thank you.
    Yes Xiomi are good phones but Miui is sometimes too much locked.
    I’m waiting for a port of lineageOS on my device 😉

    Thank you
    Have a good day !


  • developer

    Ok, If you find out anything, please just post here. Or maybe someone else with the same problem finds this thread and can post further information.

  • I’ve the same issue.
    Redmi note 7 (lavender) fresh install from yesterday of xiaomi.eu latest miui11 rom (20.1.16).
    On the previous version of the rom I had no issue.

  • I guess it isn’t in any case link to davx5. I’ve dig inside the rom permission and “read_task” permission seams to be inexitant. Think it’s an issue with the rom itself.

    @psklb which rom did you install ? the one from xiaomi.eu ?

  • Same problem here, trying to fix it, since several days and nothing worked, hope Xiaomi is going to fix this bug quickly.

    Ive written a support ticket to Xiaomi via the internal option for feedback in the settings.
    Maybe you also should do that, that it gets a higher priority.

  • @Xlm Yes : MIUI 11.2 by xiaomi.eu 20.1.2 | beta
    Ok, Beta was probably not a good choice 😞

  • @jmoegele Done !

  • Same problem here, Mi9 running xiaomi.eu ROM. Also send bug report to Xiaomi.

  • i don’t really know if it’s a miui problem or an android 10 problem…

    anyway, if you have root access to the phone, you can do the following via adb or terminal and it starts working as expected:

    pm grant at.bitfire.davdroid org.dmfs.permission.READ_TASKS
    pm grant at.bitfire.davdroid org.dmfs.permission.WRITE_TASKS

    i say i’m not sure about “miui’s fault” simply because on other xiaomi phones i’ve got, with android9 or less, everything works smootly (also with latest miui 11 beta)… this makes me assume that’s somewhat related to Q or the way davx/opentasks register their permissions…
    i don’t have another phone with Q w/out miui, so i can’t test if elsewhere is working

  • @paultt
    That worked for davx and opentasks.
    Do you know the command for acalendar?
    I still have an issue seeing my tasks there

  • Hi,
    same problem with
    Oneplus 8 pro
    Oxygen OS 10.5.8.IN11BA
    logfile says:
    requires org.dmfs.permission.READ_TASKS, or grantUriPermission


  • developer

    Does it maybe work with DAVx5 3.1? The permissions have been reworked there. There’s also app settings / Permissions now.

  • @rfc2822 app here is, is there a link to 3.1?
    Edit: found it from f-droid.
    3.1. working fine, issue solved!
    Good Job!

  • i had the same problem with a samsung S4 (GT i9515) running lineage OS (lineage-17.1-20200926-nightly-jfvelte-signed) and the latest davx5 from F-Droid (v. 3.3.2-ose).

    the slider to set the Task rights was set to granted. The debug info showed the READ_TASK as denied.

    the problem appeared after a fresh install. still i tried to uninstall both OpenTasks and davx5 and change the install order, since i remember that this used to be a solution, did not work f or me though.

    i had to use adb as described by @paultt

    here is some additional information for others who want to use adb and don’t know how to use it (like me):

    first install adb for your system, open a command prompt and then type

    user@pcname:~$ adb devices

    on your phone, allow your computer to access the phone via adb, then open an adb shell and send the command to set the permissions, like so

    user@pcname:~$ adb -d shell 
    phonename:/ $ pm grant at.bitfire.davdroid org.dmfs.permission.READ_TASKS
    phonename:/ $ pm grant at.bitfire.davdroid org.dmfs.permission.WRITE_TASKS
    phonename:/ $ exit

    i hope this helps.

  • developer

    Was it not possible to give the tasks permission in Android settings / Apps / DAVx5? (Where the button below the slider directs to)

Similar topics