Duplicate calenders and no calender syncronisation with Nextcloud



  • I had calender syncronisation issues. This is Nextcloud and LineageOS 16.

    First thing: Contact synchronization (with same account obviously) always worked!

    I noticed that in Etar there was a big problem:

    • I have three calenders in Nextcloud, but…
    • in Etar each one of these was duplicated 5 or more times and thus I had a big list of calenders with the same name and color (each). But all were set to visible, so things should™ have been shown.
    • and nothing in calenders was synchronized,

    What I did:

    • delete the DavX5 account and re-create it, test again, still did not work etc.
    • now the calender was “only” duplicated 3 times, i.e. listed 3 times for each.
    • when doing this again (deleting DavX5 account) I checked when the account was deleted and indeed all calenders were gone, so it’s not the case that there were old, unused/unassigned calenders.
    • nor creating entries on the phone, or online/from another device changed this and nothing was synced
    • there were no visible errors shown
    • (maybe important) on the same device/situation there happened also this crash (see also there for system details): https://forums.bitfire.at/topic/2168/crash-when-trying-to-enable-event-colors

    More:

    • This started some time ago, maybe with an update. At the beginning, some old entries in the calender were still there/synchronized, but no new synchronization seem to have worked.
    • Previously I did forget to disable batery optimisation, but obviously did when investing the issue.
    • DavX5 showed some warning about Huawai devices/firmware, but this is LineageOS, so this does not seem apply (after all, it’S all triggered wih manual syncs, so these are no “getting killed in background” issues).
    • the only other calender on the device is one from ICS5 (which was/is not duplicated, except for 5 minutes, were I accidentally re-added it again – deleted afterwards though)

  • developer

    Is the Lineage privacy guard disabled for DAVx⁵?


Log in to reply
 

Similar topics

  • 1
  • 6
  • 5