Sync not working with "SyncManager: Bind attempt failed"

  • Debug info:
    Verbose logging:
    Sync server: Nextcloud 16.0.5

    Steps to reproduce

    • Install Davx5 from F-Droid [1] repository on Android device
    • Add Davx5 account, which discovers all contacts and calendars from Nextcloud without an issue.
    • The initial sync takes place and all contacts and calendars are populated as one would expect.
    • Syncs fail after this, either automatic or manual initiated.

    General information

    • Manually attempting a sync produces no visible interface error.
    • Enabling verbose logging then doing a manual sync does not apparently produce any log data (see fpaste links above).
    • This has worked in the past on this phone, which is a somewhat unusual device… a Unihertz Atom, running Android 9. It stopped working, I believe, around 2 months ago.
    • Nextcloud logs so nothing. I don’t think the request is ever getting to Nextcloud. It seems to be a problem on the device.
    • One interesting and disconcerting thing is that if I try to delete a Davx5 account through the device settings, I get This change isn't allowed by your admin. In order to remove the added accounts, I seem to have to delete the entire Davx5 app from the phone.
    • adb logcat *:E reveals only this:
    11-07 16:13:07.238  2114  2248 E SyncManager: Bind attempt failed - target: ComponentInfo{at.bitfire.davdroid/at.bitfire.davdroid.syncadapter.AddressBooksSyncAdapterService}

    I noticed a much older issue/post (around 2016) here about a similar error on a Xiaomi(?) device, which was resolved, apparently, by setting some sort of “autostart” setting, but there is no similar setting on my device. Indeed, my understanding is the Android version running on my device is about as close to stock Android as you can get.

    Things I’ve tried

    • I did a factory reset of the device and reinstalled and reconfigured everything, including Davx5. This did not change anything.
    • Deleting Davx5, then reinstalling it and adding the account again. No change.

    [1] For what its worth, though I use the free F-Droid version of this app, I have been using it for years now (back to before the name change, when it was DavDroid), and I did donate at some point. This is a great app and it has been tremendously useful to me over for some years now. Thank you for this app.

  • In the possibly unlikely event that anyone else using a Unihertz Atom (or maybe any other Unihertz device) installs Davx5 and runs into this issue, the problem was that the manufacturer modifies Android to include two things called “AppBlocker” and “DuraSpeed” that prevent background apps (and apparently even foreground ones) from doing a lot of things. The AppBlocker configurations are confusingly placed under a settings menu titled “Smart Assistant”, which I never looked in because the name didn’t, to me, imply anything about blocking or otherwise crippling apps. Disabling those “features” got everything back to normal.

    Maybe this could help someone else. In my own searches for “SyncManager: Bind attempt failed” my first post here was one of the few things that came up in a Google search of any relevance.

  • developer

    @nkinkade Thanks for the update and the information. We will add Unihertz, AppBlocker and DuraSpeed to the FAQ page.

Similar topics