DavDroid SSL error ICS 4.0.4



  • Hello,

    I have a Xperia Mini Pro with locked bootloader, so the only firmare I can load is ICS 4.0.4. I installed Nextcloud client seamlessly but I got an SSL error with DavDroid 1.6 (the last one compatible with ICS afaik). I tried with different custom ROMs, the official .587, previous versions of Davdroid, and it returns me always the same error.
    Any hint?

    Attached last debug
    THXDAVdroid 1.6-ose debug info.txt


  • developer

    Hi,

    It’s most likely because your server and your Android device don’t share the same TLS ciphers. See here: https://forums.bitfire.at/topic/1445/ssl-handshake-failed/2 (including a list of ciphers in Android by version)

    Does it work when you configure matching TLS ciphers?



  • Thanks for your reply, sadly that link doesn’t help me… I’n not much more than a plain android user! The server is Nextcloud Owncloud, and in the settings panel there is no option to change TLS cyphers or something like that. And I can’t figure how to update the TLS in my android phone. Is there anything I can do?


  • developer

    Please contact your server admin with reference to this thread. They have to enable TLS ciphers which are compatible with Android 4.0.4. Otherwise, the service is just not compatible with DAVx⁵ and Android 4.0.4. You need at least Android 4.4 for modern cipher support.



  • This is the answer of the server admin:
    "Hello frazan
    this is not possible at all, as server side settings can be only adjust with SERVER packages, so your own server, not with a single account.
    Also all safe ciphers are enabled and non recommendet/safe ones not.

    Best Regards / Mit freundlichen Grüßen
    Friedrich Stagl
    OwnCube CEO & management"

    Is there anything else I can try?


  • developer

    @frazan Unfortunately, it won’t work with Android 4.0.4 then.


Log in to reply
 

Similar topics

  • 7
  • 2
  • 5