DAVx does not synchronise tasks



  • DAVx with OpenTasks does not automatically synchronise tasks with nextcloud 16.0.3.
    Tasks must be synchronised manually by the refresh button in DAVx.

    Note:
    Sync’ing calendar runs without problems


  • developer

    Hi,

    Please provide steps to reproduce, Web server and CalDAV/CardDAV server logs taken while the problem occurs, DAVx⁵ debug info (DAVx⁵ / Settings / Debug info) and verbose DAVx⁵ logs etc as described in [READ BEFORE POSTING] What’s required to diagnose a problem. Thanks!



  • @rfc2822
    Steps to reproduce:
    on the nextcloud server:

    • enable calendar and tasks apps
    • create a calendar

    in DAVx:

    • create account to access the calendar on the nextcloud server (caldav)
    • set sync intervall for tasks to say 120 minutes

    on the nextcloud server:

    • create a task (and optionally a calendar entry)

    then wait for synchronisation.

    You will see that the calendar entry will be synchronised withinm due time, but the synchronisation of the task will not occur (sync of tasks only takes place when touching the refresh icon in caldav)

    Attachment:
    debug info: https://paste.fedoraproject.org/paste/47YrPBesfgMJCLEoMsPAzQ

    Note:
    I also have enabled Verbose logging, but I do not succed in sharing the log. The email created never has an attachment (nor can I store the file by a file manager).


  • developer

    Thanks for the debug info.

    Power saving disabled: no
    Android version: 9 (PCT-L29 9.1.0.201(C432E1R2P1))
    Device: HUAWEI PCT-L29 (HWPCT)

    Looks like a power saving “feature”. Did you try the things described on https://www.davx5.com/faq/synchronization-is-not-run-as-expected? Could be that calendars will be synced in your case because the app is not put to doze within 30 min, but within 120 min.



  • I’ve made these settings (already some time before posting):

    • exclude DAVx from the system’s automatic (power) management
    • allow Auto-start, secondary start from other apps, continue executing the app in background

    I do not know, why it says “Power saving disabled: no” because there is no other settings that can be done.

    For testing purposes, I set the sync intervall for the calendar to 120 min and for tasks to 15 min.
    Result: ==> calendar is sync’ed, tasks are not


Log in to reply
 

Similar topics