• Hi Folks,

    I’m currently experiencing a similar (or even the same) issue. Here’s the setup:

    • Calendar provider is posteo.de
    • Event created on Android Pie phone - I tried with three different calendar apps -> same result
    • DAVx5 used for sync
    • ICSx5 used to retrive calendar on different phone (Android Oreo) - also tried with iCalSync -> same result

    The event is shown a day early at 2300h after sync with ICSx5 or similar app.
    The posteo web view displays everything correctly in every thinkable use case.
    Retrieving the calendar in Outlook also works fine.

    I’ve attached a log from DAVx5. Search for event “Test9”.
    I tried to analyze it myself, but didn’t really get the hang of it. Also contacted Posteo support and will keep you posted.

    So this might happen to not only be related to Lightning.

  • I noticed that the problem doesn’t occur, when I manually set the timezone of my Android to GMT+2 instead of using the timezone provided by the network. Android (Oreo/Pie) seems to know two ways to manually chose the timezone:
    a. by selecting the proper offset to UTC -> Problem does not occur
    b. by selecting the region -> problem occurs

    After timezone was set as described in a., this is what DAVx5 sent:


    So, there’s at least a workaround. It would still be nice if someone from Bitfire might take another look into this.

  • developer

    @der_Don Is this now related to Lightning or DAVx⁵? What exactly shall I have a look at? Can you please provide exact steps to reproduce the problem, and what the problem actually is? There are many confusing postings about multiple? problems before, I now don’t know what to look into / do.

  • @rfc2822 Sorry for being unspecific and causing confusion. I’ll try to explain the issue.
    I am using DAVx5 to sync my posteo.de calendar. My wife uses ICSx5 to view this calendar on her phone. When she retrieves the calendar data, events that are not marked as “all day events” come with wrong information:

    1. I create an event ( for example 2nd October, 10:15am to 12:15pm on my Android (Pie) phone using aCalendar+ (I tried with two additional calendar apps -> same result)
    2. DAVx5 syncs with posteo.de (i tried wit CalDAvSync -> same result)
    3. Event shown with correct details on my phone using DAVx5 account
    4. Calendar retrieved from posteo.de with ICSx5 on different phone (I tried wit iCalSync -> same result)
    5. Wrong event data: date 1st October, start 11pm, no end time

    So the event is always shown a day early at 23pm. Similar behaviour to what hidde encountered.
    Retrieving the shared calendar with Outlook or via feed within the Posteo web application works fine, so I can’t narrow the problem down to either one app or Posteo:

    Calendar App: I tried several ones -> same result. Unlikely that all calendar apps cause the same issue.
    DAVx5: I also tried CalDavSync -> same result. Outlook and Posteo web can handle data, so it’s unlikely DAVx5 causes the issue
    ICSx5: I also tried iCalSync -> same result. So it’s unlikely ICSx5 causes the issue.
    Posteo: Only shared calendars are affected when they are retrieved with some third party apps. Unlikely that Posteo causes the issue.
    Android: Depending on time zone settings the issue can be avoided (see my second post above). Since some apps (e.g. Outlook) can handle the data correctly, i would rule out Android as root cause.
    As you can see I cannot pin the root cause to any of the applications/providers involved.

    So the questions are: do you maybe see a reason for this? Does DAVx5 handle the data correctly? Or could it be Posteo’s handling of time zones is not very fault-tolerant/flexible/robust?

  • Hello all,

    we have exactly the same issue described by @der_Don. However I am very confident the problem is with ICSx5 or caused by unique behavior when ICSx5 is interacting with posteo.de.

    • We use ICSx5 to synchronize each other’s shared read-only calenders hosted by posteo.de.
    • Non-whole-day-events always show start at 23 pm at the previous day and no end time in the ICSx5 synchronized calendars on our android devices.
    • On other devices running e.g. Thunderbird/Lightning the same calendars look fine.
    • The issue must be with ICSx5 or with how it interacts with posteo.de

    Edit: Further Testing reveales the following:

    • Error occurs with ICSx5 and posteo.de
    • Error does not occur with Thunderbird/Lightning and posteo.de
    • Error occurs with ICSx5 and radicale (locally hosted)
    • Error does not occur with Thunderbird/Lightning and radicale (locally hosted)

    I conclude, this is a bug in ICSx5. 🕵

  • developer

    I have split this topic from the original topic.

    This one is a duplicate of https://forums.bitfire.at/post/10027, please follow up there. We’re already in contact with the author of ical4j about that.

  • developer

    I have sent an updated ICSx⁵ APK over email. Can you please tell me whether it works for you?

  • @rfc2822 Thanks a lot for fixing it.

Similar topics