Some WebCal subscriptions cannot find webcal-capable app even though ICSx5 is installed

  • developer

    @liamcooper But is, for instance, webcal:// really referenced with webcal:// in the DAVx5 properties?

    I’m 100% sure this used to work in the previous versions, because I’ve had them sync to my phone, they worked exactly the same as the other calendars, so was a bit weirded out when they didn’t work after updating.

    Maybe, I have never tested that, neither in the old, nor in the new version, because I didnt know that any server would really advertise webcal(s):// URLs. Unfortunately, the whole Webcal subscription thing isn’t even documented…

  • @liamcooper But is, for instance, webcal:// really referenced with webcal:// in the DAVx5 properties?

    The url that shows in DAVx5 properties is similar to what I said in my previous post https://serverurl/remote.php/dav/calendars/username/calendarname, but this is probably just a proxy for the webcal link.

    The Manchester_United.ics file is also available through http protocol and it works, so I’m running with that as a work around for now.

  • admin

    Please send us the davx5 debug info file. It is found in the app settings at the top.

  • @devvv4ever Sure, please find the log attached. I’ve redacted some info, and made some of the urls generic.


    I enabled verbose logging, loaded the webcal tab and tried to select the webcal calendar (which is id 8 in the collection - UK Holidays123).

    Let me know if you need anything else.

  • admin

    Thank you, I tested all the URLs and I could add them to a nextcloud test account and also subscribe to them easily from within the app (DAVx⁵ → ICSx⁵). However in your debug info there is a “UK Holidays123” entry which does not have an URL, so it can’t be headed over to ICSx⁵. If you create the account again, does it work then? Did you add the same URL twice? Can you give us access to you your account so we can test it? Otherwise we will most likely not be able to reproduce it…

  • Have you tested with the two calendars that I posted above that were causing the issue?


    These were added to my calendars in nextcloud, then tried to subscribe to them in DAVx5 but was told that I didn’t have a webcal-capable app to subscribe to them. When looking at the properties in DAVx5, it showed URLs like this https://serverurl/remote.php/dav/calendars/username/calendarname.

    I changed both calendars in the nextcloud account to use http:// instead of webcal:// and they both work now, I added UK_Holidays again as webcal:// to test for the debug info, but it still doesn’t work.

    If you can’t debug it from this, I might be able to create an account for you, but I’m not willing to share the details publicly, it would have to be through PM.

  • admin

    I will give the webcal:// URLs a test l8er!

  • I have the exact same issue. It started occurring in the latest version. Using Nextcloud webcal subscription.

  • @Taylor-Buchanan Interesting, have you tried my workaround of using http(s) protocol instead of webcal?

  • developer

    I can reproduce the problem with webcal:// subscription URLs. As said above, this URL scheme has never been tested with DAVx⁵, so if it worked previously, it was pure luck.

    Shouldn’t be too hard to get it working though.

  • developer

    Should be fixed with / 2.5.1, will send an APK for testing.

    For testing:

    1. Install the new APK
    2. Open DAVx⁵ and the account
    3. Switch to Webcal tab
    4. Swipe down to refresh the Webcal list
    5. Subscribing to webcal(s):// URLs should now work

Log in to reply

Similar topics

  • 3
  • 3
  • 8