DAVx5 2.4: Account activity doesn't react when not all permissions are granted


  • developer

    This should be fixed with DAVx⁵ 2.4.0.1, which displays a “Snackbar” when permissions are denied forever (“Don’t ask anymore”), instead of running into an endless loop.

    Can you confirm that this works with DAVx⁵ 2.4.0.1 and/or when you give the required permissions to DAVx⁵ manually?



  • Hello,

    I tested version 2.4 with temporally granted permission for contacts. This works.
    I cannot test v2.4.0.1, because it is not yet available on F-droid.

    However, contact permissions have been denied/missing for the past 2 years without any problems. I do not sync my contacts for various reasons and therefore deny permission to access contacts to any app that does not absolutely need it. Any version before v2.4 worked fine: The app worked (did not crash), calendar was synced, contacts were not.

    As soon as it becomes available, I will test v2.4.0.1 and report back.

    Best

    Moses


  • developer

    This post is deleted!


  • Hm, that snackbar notification is only shown for a very short period of time (one or two seconds at most). Very little time to click the “FIX” button



  • I’m also not sure, if this notification should be shown over and over again, whenever the account settings are opened.



  • We’ve discussed this already internally yesterday. We don’t want to bother users that are fine with the fact not having granted all permissions. Otherwise we want to show people that maybe have missed granting permissions a “soft” way to fix that. In android these toasts can only be short, long (currently used) and permanent.

    If you have other suggestions that work better we may consider changing the behaviour 😃



  • It feels a bit odd to continuously show this notification, when the user has explicitly chosen to not grant this permission.

    At the very least, I would only show the toast notification if the user actually has an address book selected for syncing.
    Is there a point to show this notification if no address book has been selected?



  • Currently the permission toast would also be shown if there is no address book selected. If there is no CardDAV section then there would also be no permissions toast for the contacts permission. Nevertheless @rfc2822 is currently already working on something on that matter. I think she will improve the behaviour in the near future.



  • @devvv4ever thanks for the update



  • Version 2.4.0.1 finally is available on F-Droid. I tested it and so far it seems to work finr again.

    Thanks.


Log in to reply
 

Similar topics