• I’m running the CardDAV server locally, with no internet access, on a Synology NAS. The phone and account have no trouble connecting, no error syncing. It all worked seamlessly on Android 7, but just stopped working on Android 8. I have deleted the app and reinstalled (apk from f-droid) multiple times. I also got the newest version from Google Play (2.4), but that doesn’t help either. I also reset the contacts app many times as well. Attaching the debug file, since the verbose logging doesn’t work for me (Whenever I push “Send log” and select the appropriate method, it never sends or saves). I have also noticed, that if I tried to create a new address book, it always comes back as “HTTP 403 Forbidden”, though everything works on other phones and the earlier mentioned android version.

    Debug info:

  • developer

    Can you view the logs with adb? https://www.davx5.com/faq/how-to-debug#c77

    (Whenever I push “Send log” and select the appropriate method, it never sends or saves)

    Did you try to send over email?

  • I can look through ADB.


    Please excuse the failed connections, I was on the wrong Wi-Fi.

  • developer

    Thanks When DAVx⁵ sends a PROPFIND request, the server closes the connection with ECONNABORTED:

    2019-04-01 15:10:29 677 [HttpClient] --> PROPFIND
    2019-04-01 15:10:41 677 [HttpClient] <-- HTTP FAILED: java.net.ConnectException: Failed to connect to /
    2019-04-01 15:10:41 677 [syncadapter.SyncManager] I/O error
    EXCEPTION java.net.ConnectException: Failed to connect to /
    	at okhttp3.internal.connection.RealConnection.connectSocket(RealConnection.java:249)
    	at okhttp3.internal.connection.RealConnection.connect(RealConnection.java:167)
    Caused by: java.net.ConnectException: failed to connect to / (port 8443) from / (port 39496) after 15000ms: isConnected failed: ECONNABORTED (Software caused connection abort)
    	at okhttp3.internal.connection.StreamAllocation.newStream(StreamAllocation.java:114)

    Sounds like a connectivity / firewall / network problem. Can you access with a browser on the Android device?

  • @rfc2822 I can’t. But I’m flustered because, if it was a connectivity problem, it shouldn’t work on other phones as well, correct?

  • developer

    @mazeiva I don’t know. We’d have to know the actual reason why it’s not working to say why it’s working on other devices.

    Maybe you can find something in your server (for instance, do the DAVx⁵/browser requests make it through to the server) and/or firewall logs?

Similar topics