Nextcloud "no access to CalDAV or CardDAV service" with the right credentials

  • I have a Nextcloud server wich is up to date and perfectly working. It’s installed on an OVH mutal webserver. Now I’m trying to sync my agenda with my Android device and this is where I’m stuck.

    I tried using the “sync” option in the Nextcloud android app and directly opening the Davx5 (also up to date) app. I tried using both & adress to connect with my Nextcloud login and password. I didn’t enable the two factor authentification or device specific password. I don’t know if that’s relevant but I also have an OnlyOffice installation (on a separate server) that’s working well with my Nextcloud.

    I also tried to connect Davx5 with both wifi and mobile data. I can’t find any more solution to try. I’m kinda new to all that stuffs and I don’t really understand what my Davx5 logs are saying so here it is :

    Thanks in advance !

  • developer


    You’re most probably suffering from a server error. Did you have a look at Nextcloud logs and your Web server logs?

  • My Nextcloud logs are empty. I did checked my web server logs and here they are :

    web logs :

    error logs :

    [Fri Mar 29 00:25:20 2019] [crit] [client] [host] (13)Permission denied: AH00529: /homez.88/yunirucozj/www/nextcloud/data/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable and that '/homez.88/yunirucozj/www/nextcloud/data/' is executable
    [Fri Mar 29 00:26:23 2019] [crit] [client] [host] (13)Permission denied: AH00529: /homez.88/yunirucozj/www/nextcloud/data/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable and that '/homez.88/yunirucozj/www/nextcloud/data/' is executable

    Note that in the error logs, the client ip is coming from my Android device

  • developer

    2019-03-26 16:31:47 1121 [ui.setup.DavResourceFinder] Couldn’t detect services on
    EXCEPTION okhttp3.internal.http2.StreamResetException: stream was reset: INTERNAL_ERROR
    at okhttp3.internal.http2.Http2Stream$
    at okhttp3.internal.http2.Http2Codec$
    at okio.RealBufferedSource.exhausted(

    The server seems to reset the connection. Which Web server (and version) are you using? Is your HTTP/2 configuration correct? Does it work when you turn of HTTP/2?

  • @rfc2822 I’m using an OVH web server. This one and I didn’t touch anything in the HTTP/2 configuration and I don’t think that I’m able to turn it off

  • developer

    @Yuniru I see. Maybe ask the hoster about this?

  • @rfc2822 Ok so, after asking to my hoster I successfully solved this problem by making some changes in the htaccess file and in my server configuration.

    Now Davx5 actually connect to nextcloud, but when I try to sync I get an error “services detection failed - Impossible to refresh collections’ list” (I’m translating the message so it’s probably not exactly the same as in english).

    Here is my Davx5 logs after that :

    My Nextcloud logs does show something new :

    [PHP] Error: PDO::query(): Error reading result set's header at /home/yunirucozj/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php#104
    GET /index.php/settings/admin/overview
    from by Admin at 2019-03-29T17:26:09+00:00

    My web server logs contain this new line :

    [Fri Mar 29 18:24:58 2019] [error] [client] [host] Script timed out before returning headers: index.php
  • developer

    These are internal server errors. It’s most probably not a DAVx5 problem. Unfortunately, I don’t know what’s wrong with your server.

  • @Yuniru i’ve you solved your problem ? I’ve the same and don’t find an issue…
    I don’t know if it’s server error or davx5 problem !

  • Is it possible that you have multifactor turned on for Nextcloud?

    If so, you can create a one-time password in your NC settings.

Similar topics