New contacts not being sent to Baikal Server

  • Hi, I recently upgraded my Android phone to LineageOS 15.1 and now when I add new contacts on my phone, they will not sync to my Baikal server. I am not getting any errors. In order to make it work, I have to add new contacts on my desktop computer and then they will sync to my phone which is a nuisance. I didn’t have this issue before I upgraded. Verbose log can be found here. Thank you!

  • developer

    Hello… sounds like you didn’t select the DAVx⁵ address book when creating a contact. May that be the reason? If not, please provide steps to reproduce and DAVx⁵ debug info (DAVx⁵ / Settings / Debug info).

    The logs show only one contact being uploaded:

    2019-03-24 10:17:31 1434 [syncadapter.ContactsSyncManager] Preparing upload of VCard 78a9725f-c48f-439a-9e26-8380cfea5696.vcf
    	PARAMETER #0 = at.bitfire.vcard4android.Contact@c2abb69[addresses=[],anniversary=<null>,birthDay=<null>,categories=[],displayName=Atest Atest,emails=[],familyName=Atest,givenName=Atest,group=false,impps=[],jobDescription=<null>,jobTitle=<null>,members=[],middleName=<null>,nickName=<null>,note=<null>,organization=<null>,phoneNumbers=[LabeledProperty( [ group=null | parameters={TYPE=[cell]} | uri=null | text=(714) 994-4400 ], label=null)],phoneticFamilyName=<null>,phoneticGivenName=<null>,phoneticMiddleName=<null>,prefix=<null>,relations=[],suffix=<null>,uid=78a9725f-c48f-439a-9e26-8380cfea5696,unknownProperties=<null>,urls=[]]
    PRODID:+//IDN ez-vcard/0.10.5
    FN:Atest Atest
    TEL;TYPE=cell:(714) 994-4400

    This contact has been uploaded successfully, according to the server’s response.

  • I deleted the test contact off of my phone and then added it again and now it is showing up on my desktop. Perhaps I didn’t have the DAVx⁵ addressbook selected the last time, but that’s what it defaults to and I know that I wouldn’t have changed it… Strange? Anyway, thank you for taking a look at this. Much appreciated! 😉

Similar topics