• Hello everyone,

    I have a SYNOLOGY DS218 play.
    DAVx5 worked very well when I was under LineageOS 15.1, i.e. Android 8.1.
    Since my time on LineageOS 16, Android 9, I have been having problems.

    I have 2 accounts to synchronize. When I set up my A account, I only have access to CardDav and no more CalDav. I can no longer also synchronize my B account.
    Strangely, when I reset DAVx5, I can configure my account B but no longer my account A. And I still don’t have access to my calendar. However, I followed the instructions here https://www.davx5.com/tested-with/synology/.
    I get a message when I try to configure my 2nd account “No access possible CaldDAV or CardDAV.”
    Here is the detailed message davx5-info.txt

    If you have any ideas, I’m a buyer 😉
    Thank you.

  • admin


    I see you used as URL
    Maybe try without the appended “addressbook”. This should only be used for pretty old servers. But I think your DMS should have gotten updates.

    Also there is an “unauthorized exception”. So the connection is working but you’re not allowed to access it with the given credentials.

    Maybe this information helps…

  • Hi devvvv4ever,
    Thank you for your answer.
    In the meantime, I have reset my SYNOLOGY and it works 😀
    What I don’t understand is that the CalDAV and CardDAV packages were up to date and synchronized with another phone with the format http(s)://example.com:port/addressbooks/users/YOUR_USERNAME/addressbook.
    In short, the important thing is that it works.
    Have a good day.

  • Hello,

    As resetting the Synology wasn’t a possible solution, re-install the app worked for me.

    Works also by using application settings and reverse proxy:

    Contacts - reverse proxy:


    Calendar - application settings:



Similar topics

  • 7
  • 4
  • 5