DAVdroid doesn't keep sync interval settings after reboot on Android 9



  • Hi

    I have almost the same issue as described here. The other thread is marked as solved, so I'm creating a new one.

    HW/SW:
    Nokia 6.1 (TA-1043) with Android 9.0 (Android One), Security Patch Level Oct 1st
    DAVdroid 2.0.5 installed from F-Droid
    Probably not relevant: Server is running nextcloud 14.0.3

    Issue:
    Installing and syncing works like a charm, no problem so far. Sync interval is set to default (every 240min and immediately when locale changes). Battery optimizing for DAVdroid is set to "not optimized", as suggested by DAVdroid during first run. Pretty every other setting on the phone is at its defaults (phone is just a spare phone, only google sync is disabled).
    After a shutdown/reboot, the sync interval is set to manual only. No mater what I do, it switches back to manual only after every reboot.
    I tried switching off the battery manager (Settings -> Battery -> Battery-Manager [german: Einstellungen -> Akku -> Intelligenter Akku -> Funktion "Intelligenter Akku" verwenden]), no change.
    I did not find any other battery saving features on my phone.

    Î tested this behavior on my HTC 10 with some unofficial LineageOS 16.0 build (28 Oct). Same settings but no issue. Sync interval is kept after reboot. So this seems some power saving features on my Nokia, unhappily the solution mentioned by
    RandomUsername did not help (sync is switched on) nor did I find any similar settings as described in the FAQ...

    Is this a Android 9.0 issue? Is this a "Nokia" issue? Or are there any settings I'm missing? Anyone got an idea?
    (I can provide debug info, i just don't know the best time to collect it, maybe after reboot?)

    Thanks, Michael



  • Well, somehow found the solution. In Android 8.1 the issue didn't occur. After the Pie update the sync interval setting did not stick anymore. Well, I set the phone back to factory defaults and it works...
    Let's face the next issue after the reset, spell checking does not work anymore. But probably not a issue with DAVdroid 😂


  • developer

    @mic Happy to hear that it now works for you. Whatever the real cause was...



  • Hey mic,
    I had the same issue, also running on Nextcloud 14.0.3 and on a Nokia 8 with Android 8.1.
    So like I found out recently the problem wasn't solved the last time. Maybe it is no coincidence that the combination of Nokia and nextcloud has problems?



  • Hi,

    I don't think nextcloud is involved, since the sync settings are stored on the Android side. It must be some internal setting or problem of Android itself, because users of other device manufacturers also reported this over the last years, however it was a rather rare issue and we never could reproduce it except from the "maximum power saving issue" (Samsung devices only) which reproducibly sets sync to manual.