• Hi,

    Trying to sync a FastMail account which I have configured to use my own domain. I followed the FastMail services tutorial, but it does not seem to work. I get the error: Couldn’t find CalDAV or CardDAV service.

    I think DAVDroid tries to connect to my own domain name instead of FastMail’s. Is this possible to be fixed?

    Here is the log file: (domain name has been renamed for privacy)


  • developer


    Do you have an email address at fastmail, but with another domain as fastmail.com (or their other domains)? I didn’t know this case exists.

    In this case, you’d have to use “Login with base URL” and use

    Does that work?

    Of course, you can also set up SRV record for your custom domain so they point to they point to Fastmail. Then you can use the “login with email” method.

  • Hi rfc2822,

    I have tried with the Base URL (Login with URL and user name), but still to no avail. I have tried both cases of typing the username with and without the domain part in the username field. I don’t have another Email address associated with the fastmail.com domain, but I’ll check again in case I have missed something.

    Log from using the Base URL with username including domain part.


  • developer

    @perov Seems like the SRV records are not available over DNS. Which connection type do you use (WiFi/mobile data)? Can you try with a different connection type?

  • Thanks for the feedback @rfc2822! I tried over 4G (previously I was using WiFi) without success, but now I can see that the FastMail return 401 Unauthorized for my user. Alternatively, I tried connecting to caldav.fastmail.com as they described in on their side, but that failed with 401, too.


    This looks more like a FastMail issue, or?

    Ignore what I wrote. 🙂 I was missing a letter from the FastMail generated app password. My bad! It works now with the https://caldav.fastmail.com/dav/ url.

    Thank you!

  • developer

    This post is deleted!

Similar topics