davdroid do not get the ssid of the current wifi



  • Hi guys,

    I have got a problem with my oneplus 5t and the limitation to sync in a specific network.
    At home there is a radical server and i want sync my calendar stuff only at home.
    Unfortunately it seems so that davdroid do not get the ssid of the current wifi.
    All right for dav droid are given, also location.
    And it seems that the sync interval are not correct. Sometimes davdroid sync if the display is going to turned on.
    Here comes the debug info:
    https://paste.fedoraproject.org/paste/eVvySafgvU7FQa5FWDmzbA

    A part of the log where the ssid will be checked:

    2018-05-30 08:32:03 372 [AccountSettings] Account michael has version 8, current version: 8
    2018-05-30 08:32:03 372 [settings.Settings] Looking for setting wifi_only
    2018-05-30 08:32:03 372 [settings.Settings] DefaultsProvider: has wifi_only = false, continue: true
    2018-05-30 08:32:03 372 [settings.Settings] SharedPreferencesProvider: has wifi_only = false, continue: true
    2018-05-30 08:32:03 372 [settings.Settings] Looking for setting wifi_only -> false
    2018-05-30 08:32:03 372 [settings.Settings] Looking for setting wifi_only_ssids
    2018-05-30 08:32:03 372 [settings.Settings] DefaultsProvider: has wifi_only_ssids = false, continue: true
    2018-05-30 08:32:03 372 [settings.Settings] SharedPreferencesProvider: has wifi_only_ssids = false, continue: true
    2018-05-30 08:32:03 372 [settings.Settings] Looking for setting wifi_only_ssids -> false
    2018-05-30 08:32:03 372 [settings.Settings] Looking for setting wifi_only_ssids
    2018-05-30 08:32:03 372 [settings.Settings] DefaultsProvider: has wifi_only_ssids = false, continue: true
    2018-05-30 08:32:03 372 [settings.Settings] SharedPreferencesProvider: has wifi_only_ssids = false, continue: true
    2018-05-30 08:32:03 372 [settings.Settings] Looking for setting wifi_only_ssids -> false
    2018-05-30 08:32:03 372 [settings.Settings] Looking up setting contact_group_method
    2018-05-30 08:32:03 372 [settings.Settings] DefaultsProvider: value = null, continue: true
    2018-05-30 08:32:03 372 [settings.Settings] SharedPreferencesProvider: value = null, continue: true
    2018-05-30 08:32:03 372 [settings.Settings] Looked up setting contact_group_method -> null
    2018-05-30 08:32:03 372 [settings.Settings] Looking for setting manage_calendar_colors

    Hope someone could help me. I love this App and its features for have a private calendar .

    Thank you in advanced.


  • developer

    Hello,

    Are location services active? See https://www.davdroid.com/faq/wifi-ssid-restriction-location-permission/:

    ..., it's necessary ...

    • to have the location permission,
    • that location services are actually active (usually by enabling "location" in the Android quick settings).


  • Hey,

    thank you for this quick answer.
    Yes they are always on, high precision (GPS, Wifi, mobile and bluetooth).
    Under location setting I see the last location requests, davdroid does not appear there.


  • developer

    Unfortunately it seems so that davdroid do not get the ssid of the current wifi.

    How do you notice this?

    And it seems that the sync interval are not correct. Sometimes davdroid sync if the display is going to turned on.

    Did you enable "app auto-launch" for DAVdroid as described on https://www.davdroid.com/faq/automatic-synchronization-is-not-run-as-expected/?

    I guess your problem is not related to the WiFi SSID, but to "app auto-launch" (a OnePlus function that blocks apps like DAVdroid by default).

    Please provide more details about the actual problem and how you find out about it, and about your "app auto-launch" settings.



  • *Unfortunately it seems so that davdroid do not get the ssid of the current wifi.

    How do you notice this?*

    I expected the info about ssid here:

    CONNECTIVITY (at the moment)
    Active connection: WiFi, CONNECTED

    But now I think you don't log it in the debug info. I'm sorry for that assertion.
    But the location were not requests by the davdroid app, is this okay if a ssid is set?

    Did you enable "app auto-launch" for DAVdroid as described on https://www.davdroid.com/faq/automatic-synchronization-is-not-run-as-expected/?

    The only thing I could change is the battery optimization, and this set to not optimized.

    The debug log also say this:
    Power saving disabled: yes

    It seems to be not possible to change the auto start behavior. Other forums say this is removed with the Oreo Update.
    https://www.reddit.com/r/oneplus/comments/7nerj7/autostart_apps_on_5t_oreo/

    They merged this setting with the battery settings, the last entry say this:
    https://forums.oneplus.com/threads/apps-auto-launch-after-reboot-for-oreo.752696/



  • I think I found the solution,it seems the missing setting was Apps -> special access -> Modify system settings -> davdroid -> Allow modify system settings -> On.

    If I sync now in the davdroid app no connection error will appear.
    I am going to observe this behavior.
    Thank you for your help.


  • developer

    @m-ichi-one Thanks for the update! I'm happy that it now works for you.