• After upgrading to 1.11-ose from F-Droid the synchronization of a not empty (500 contacts) Zimbra addressbook (no problem with calendar, tasks and empty addressbook) raise this error:

    MyAddressBook (info@mydomain.it WA)
    local storage error - %s

    Debug log: https://paste.fedoraproject.org/paste/JfNt30iJBFUw0UbfSTXK8g

    Sometimes also this error appear: the process android.process.acore has stopped

    I try a lot of things without success, like clear cache, re-install, create and sync a new empty addressbook copying a small amount of contacts into it (the error appear after 20/30 contacts and stay there even if I delete some).

    Thanks for your help

  • developer


    Looks like some error in the Android contacts storage (maybe caused by previous Android upgrades). Can you try to:

    1. make a backup of your contacts
    2. Android Settings / Apps / System apps / Contacts storage (com.android.provider.contacts)
    3. Storage / Delete data

    This will reset your contacts storage and delete all local contacts. At the next sync, they should be downloaded again.

    Does this work for you?

  • Contacts storage (com.android.provider.contacts)

    I already try this … but strangely now I’m not able to see Contacts storage neither com.android.provider.contacts (I see Preferred Contact and Google Contacts)

  • This post is deleted!

  • This post is deleted!

  • After many test I can say that this is a Davdroid problem: the contacts download cause the crash of process android.process.acore.

    I had to export from Zimbra and import on Google Contacts to restore my contacts (a solution that I really doesn’t like 😕 ).

  • developer

    @orsomannaro said in local storage error syncing addressbook:

    After many test I can say that this is a Davdroid problem: the contacts download cause the crash of process android.process.acore.

    I had to export from Zimbra and import on Google Contacts to restore my contacts (a solution that I really doesn’t like 😕 ).

    I don’t understand that because android.process.acore does not belong to DAVdroid.

    Is there any way to reproduce this problem? I’d really like to find a solution but everything is working here.

  • Hi, since some days I get exactly the same error. Here is the debug.txt
    I can confirm that the “acore” breakdown is definitely connected to DAVdroid address book sync. It occurs only when I mark the contacts to be synced. The calendar sync works fine if the contacts are not marked.
    With the proprietary app of my mail service (gmx.net), the contacts are synced without a problem, but when I use DAVdroid and the storage error occurs, it seems to corrupt the whole contact list until I switch it off again.
    I hope this can be solved because I like DAVdroid much more for it’s simplicity.

  • From the debug.txt I just noticed that we use (almost) the same smartphone and android version. Maybe it is something very specific. Looks like this could make the debugging much more complicated. Any suggestions what we could try or additional information that could be useful?

  • developer

    Unfortunately, I don’t have an idea… and I guess it’s very specific, too. If you find out anything new, please let us know.

  • Hi, I am seeing the same error, the issues started as soon as I upgraded to DAVdroid 1.11-gplay. I have two Samsung galaxy devices which sync to the same Card DAV address books the device running DAVdroid 1.10 continues to work however the device that was updated to 1.11 shows the local storage error - %s error.

    I have reinstalled DAVdroid and deleted the android contacts database however the error continues.

    debug file;


  • developer

    @cevans Hello, the debug logs are not accessible…

  • Same problem here with a bq M4.5 since a few days.

    Tried with two devices, one with Android 5.1 and one with Android 6. Unfortunately I cannot copy the log for some reason.

    Thanks for having a look into this!

  • developer

    @spot Unfortunately, we still don’t have an idea what the problem could be or how it could be reproduced. Any hints are appreciated…

  • developer

    The problem seems to occur primarily on Samsung devices with Android 5 or 6. Accessing SyncState seems to crash the contacts provider or some other important Android processes on those devices, so that further sync operations fail.

    I’m working on a version which doesn’t use ContactsContract.SyncState for testing purposes.

  • developer

    I was able to reproduce the problem on Android 5 and I guess the problem is caused by a memory leak which should be fixed with vcard4android/4da2606a.

    I have sent another APK over email. Please tell me whether it now works for you.

  • @rfc2822 Have installed memory leak APK at initial force sync shows no errors. Will provide an update after a scheduled sync and some contact data changes. Looks very promising! thank you so much for your help.

  • Hi

    I started getting this error today, the problem is that my contact list is emptied out after this but I get my contacts back after a restart, I do not know what is going on?

    I have been using Davdroid for years, never had this issue. Also, I have not upgraded Davdroid for quite sometime. I also did not upgrade any of my system stuff. SO this has nothing to do with upgrades, it is weird that this issues suddenly started and experienced by peopel around the same time.

    I am using Davdroid (Fdroid version) on Samsung Note 4, Lollipop with Nextcloud server.

    Can i get a hold of the new apk as well?

  • @tartarian Hi, I was seeing the same issue with the default Android contacts client however, the latest DAVdroid build seems to have resolved all the issues. Sync is working perfectly in both directions and the contacts app is behaving correctly.

Similar topics

  • 3
  • 1
  • 4